<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8" ><meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" /><link rel="pingback" href="https://knowtechie.com/xmlrpc.php" /><meta property="og:image" content="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/macbook-air-on-table-1000x600.jpg" /><meta name="twitter:image" content="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/macbook-air-on-table-1000x600.jpg" /><meta property="og:type" content="article" /><meta property="og:description" content="Students need a reliable laptop for school, and MacBooks deliver." /><meta name="twitter:card" content="summary"><meta name="twitter:url" content="https://knowtechie.com/which-macbook-should-i-buy-for-college/"><meta name="twitter:title" content="Which MacBook should I buy for college?"><meta name="twitter:description" content="Students need a reliable laptop for school, and MacBooks deliver."> <script>function fvmuag(){if(navigator.userAgent.match(/x11.*fox\/54|oid\s4.*xus.*ome\/62|oobot|ighth|tmetr|eadles|ingdo/i))return!1;if(navigator.userAgent.match(/x11.*ome\/75\.0\.3770\.100/i)){var e=screen.width,t=screen.height;if("number"==typeof e&&"number"==typeof t&&862==t&&1367==e)return!1}return!0}</script><script>function loadAsync(e,a){var t=document.createElement("script");t.src=e,null!==a&&(t.readyState?t.onreadystatechange=function(){"loaded"!=t.readyState&&"complete"!=t.readyState||(t.onreadystatechange=null,a())}:t.onload=function(){a()}),document.getElementsByTagName("head")[0].appendChild(t)}</script> <title>Which MacBook should I buy for college? | KnowTechie</title><meta name="description" content="Apple has long been associated with higher education, with solidly-built MacBooks that minimize the number of disruptions students may face." /><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://knowtechie.com/which-macbook-should-i-buy-for-college/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Which MacBook should I buy for college? | KnowTechie" /><meta property="og:description" content="Apple has long been associated with higher education, with solidly-built MacBooks that minimize the number of disruptions students may face." /><meta property="og:url" content="https://knowtechie.com/which-macbook-should-i-buy-for-college/" /><meta property="og:site_name" content="KnowTechie" /><meta property="article:publisher" content="https://www.facebook.com/KnowTechie" /><meta property="article:author" content="https://facebook.com/iWalkingCorpse" /><meta property="article:published_time" content="2020-08-20T20:05:50+00:00" /><meta property="og:image" content="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/macbook-air-on-table.jpg" /><meta property="og:image:width" content="1600" /><meta property="og:image:height" content="900" /><meta property="fb:app_id" content="706420082767874" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@https://twitter.com/iWalkingCorpse" /><meta name="twitter:site" content="@KnowTechie" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://knowtechie.com/#organization","name":"KnowTechie","url":"https://knowtechie.com/","sameAs":["https://www.facebook.com/KnowTechie","https://www.instagram.com/knowtechie/","https://www.youtube.com/channel/UCjpgYyUblbKvNtElLOFi2jw","https://www.pinterest.com/KnowTechie/","https://twitter.com/KnowTechie"],"logo":{"@type":"ImageObject","@id":"https://knowtechie.com/#logo","inLanguage":"en-US","url":"https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2015/04/LOGO-ICON-KNOW-TECHIE-FINAL01-01-COLOR.png","width":207,"height":195,"caption":"KnowTechie"},"image":{"@id":"https://knowtechie.com/#logo"}},{"@type":"WebSite","@id":"https://knowtechie.com/#website","url":"https://knowtechie.com/","name":"KnowTechie","description":"Daily Tech News for the Non-Techie","publisher":{"@id":"https://knowtechie.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://knowtechie.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://knowtechie.com/which-macbook-should-i-buy-for-college/#primaryimage","inLanguage":"en-US","url":"https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/macbook-air-on-table.jpg","width":1600,"height":900,"caption":"Image: Unsplash"},{"@type":"WebPage","@id":"https://knowtechie.com/which-macbook-should-i-buy-for-college/#webpage","url":"https://knowtechie.com/which-macbook-should-i-buy-for-college/","name":"Which MacBook should I buy for college? | KnowTechie","isPartOf":{"@id":"https://knowtechie.com/#website"},"primaryImageOfPage":{"@id":"https://knowtechie.com/which-macbook-should-i-buy-for-college/#primaryimage"},"datePublished":"2020-08-20T20:05:50+00:00","dateModified":"2020-08-20T20:05:50+00:00","description":"Apple has long been associated with higher education, with solidly-built MacBooks that minimize the number of disruptions students may face.","breadcrumb":{"@id":"https://knowtechie.com/which-macbook-should-i-buy-for-college/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://knowtechie.com/which-macbook-should-i-buy-for-college/"]}]},{"@type":"BreadcrumbList","@id":"https://knowtechie.com/which-macbook-should-i-buy-for-college/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://knowtechie.com/","url":"https://knowtechie.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://knowtechie.com/which-macbook-should-i-buy-for-college/","url":"https://knowtechie.com/which-macbook-should-i-buy-for-college/","name":"Which MacBook should I buy for college?"}}]},{"@type":["Article","NewsArticle"],"@id":"https://knowtechie.com/which-macbook-should-i-buy-for-college/#article","isPartOf":{"@id":"https://knowtechie.com/which-macbook-should-i-buy-for-college/#webpage"},"author":{"@id":"https://knowtechie.com/#/schema/person/94d8f42b79df789cb445b73ea73c0d18"},"headline":"Which MacBook should I buy for college?","datePublished":"2020-08-20T20:05:50+00:00","dateModified":"2020-08-20T20:05:50+00:00","mainEntityOfPage":{"@id":"https://knowtechie.com/which-macbook-should-i-buy-for-college/#webpage"},"commentCount":0,"publisher":{"@id":"https://knowtechie.com/#organization"},"image":{"@id":"https://knowtechie.com/which-macbook-should-i-buy-for-college/#primaryimage"},"keywords":"Apple,Gadgets,MacBook,MacBook Air,Macbook Pro,News","articleSection":"Apple,Gadgets","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://knowtechie.com/which-macbook-should-i-buy-for-college/#respond"]}],"copyrightYear":"2020","copyrightHolder":{"@id":"https://knowtechie.com/#organization"}},{"@type":"Person","@id":"https://knowtechie.com/#/schema/person/94d8f42b79df789cb445b73ea73c0d18","name":"Joe Rice-Jones","image":{"@type":"ImageObject","@id":"https://knowtechie.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/0fb7845ad2813665b192f1347d9f266f","caption":"Joe Rice-Jones"},"description":"Maker, meme-r and unabashed geek. Hardware guy here at KnowTechie, if it runs on electricity (or even if it doesn't) I probably have one around here somewhere. My hobbies include photography, animation and hoarding Reddit gold.","sameAs":["https://facebook.com/iWalkingCorpse","https://www.instagram.com/joericejones/","https://www.linkedin.com/in/joe-rice-jones-03115b127/","https://twitter.com/https://twitter.com/iWalkingCorpse"]}]}</script> <script>advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();</script> <link rel='stylesheet' id='mvp-fonts-css'  href='//fonts.googleapis.com/css?family=Advent+Pro%3A700%7CRoboto%3A300%2C400%2C500%2C700%2C900%7COswald%3A300%2C400%2C700%7CLato%3A300%2C400%2C700%7CWork+Sans%3A200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7COpen+Sans%3A400%2C700%2C800%7CRoboto+Condensed%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900&#038;subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese' type='text/css' media='all' /><link rel='stylesheet' id='fvm-header-0-css'  href='https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/cache/fvm/1597930409/out/header-ebdd8fd3b68bd50d8493d57316ff0442c8c84154.min.css' type='text/css' media='all' /> <script type='text/javascript' src='https://mk0knowtechie1qof48y.kinstacdn.com/wp-includes/js/jquery/jquery.js' id='jquery-core-js'></script><link rel="https://api.w.org/" href="https://knowtechie.com/wp-json/" /><link rel="alternate" type="application/json" href="https://knowtechie.com/wp-json/wp/v2/posts/127111" /><link rel="alternate" type="application/json+oembed" href="https://knowtechie.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fknowtechie.com%2Fwhich-macbook-should-i-buy-for-college%2F" /><link rel="alternate" type="text/xml+oembed" href="https://knowtechie.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fknowtechie.com%2Fwhich-macbook-should-i-buy-for-college%2F&#038;format=xml" /><meta name="msvalidate.01" content="2A9F9F4152194D81E03CB4F0B0AA728E" /> <script type="text/javascript" src="https://code.jquery.com/jquery-2.2.4.min.js"></script> <script>$ = jQuery;</script><style type="text/css" id="custom-background-css">body.custom-background { background-color: #f4f4f4; }</style> <script data-ad-client="ca-pub-5956380843928535" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><link rel="icon" href="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2015/04/cropped-LOGO-ICON-KNOW-TECHIE-FINAL01-01-COLOR-32x32.png" sizes="32x32" /><link rel="icon" href="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2015/04/cropped-LOGO-ICON-KNOW-TECHIE-FINAL01-01-COLOR-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2015/04/cropped-LOGO-ICON-KNOW-TECHIE-FINAL01-01-COLOR-180x180.png" /><meta name="msapplication-TileImage" content="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2015/04/cropped-LOGO-ICON-KNOW-TECHIE-FINAL01-01-COLOR-270x270.png" /></head><body class="post-template-default single single-post postid-127111 single-format-standard custom-background"><div id="mvp-fly-wrap"><div id="mvp-fly-menu-top" class="left relative"><div class="mvp-fly-top-out left relative"><div class="mvp-fly-top-in"><div id="mvp-fly-logo" class="left relative"> <a href="https://knowtechie.com/"><img src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2017/03/logo-pixlr-1.png" alt="KnowTechie" data-rjs="2" /></a></div></div><div class="mvp-fly-but-wrap mvp-fly-but-menu mvp-fly-but-click"> <span></span> <span></span> <span></span> <span></span></div></div></div><div id="mvp-fly-menu-wrap"> <nav class="mvp-fly-nav-menu left relative"><div class="menu-knowtechie-top-menu-container"><ul id="menu-knowtechie-top-menu" class="menu"><li id="menu-item-44918" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-44918"><a href="https://knowtechie.com/category/news/">News</a><ul class="sub-menu"><li id="menu-item-104190" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104190"><a href="https://knowtechie.com/tag/gametechie">#GameTechie</a></li><li id="menu-item-104191" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104191"><a href="https://knowtechie.com/tag/google/">Google</a></li><li id="menu-item-104192" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104192"><a href="https://knowtechie.com/tag/android/">Android</a></li><li id="menu-item-104193" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104193"><a href="https://knowtechie.com/tag/ios/">iOS</a></li><li id="menu-item-104194" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104194"><a href="https://knowtechie.com/tag/facebook/">Facebook</a></li><li id="menu-item-104202" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104202"><a href="https://knowtechie.com/tag/amazon/">Amazon</a></li><li id="menu-item-104203" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104203"><a href="https://knowtechie.com/tag/apple">Apple</a></li><li id="menu-item-104288" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104288"><a href="https://knowtechie.com/tag/gadgets/">Gadgets</a></li><li id="menu-item-104298" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104298"><a href="https://knowtechie.com/tag/microsoft/">Microsoft</a></li><li id="menu-item-104302" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104302"><a href="https://knowtechie.com/tag/wtf/">WTF</a></li></ul></li><li id="menu-item-44920" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44920"><a href="https://knowtechie.com/category/reviews/">Reviews</a></li><li id="menu-item-44921" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-44921"><a href="https://knowtechie.com/category/gadgets/">Gadgets</a><ul class="sub-menu"><li id="menu-item-104214" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104214"><a href="https://knowtechie.com/tag/apple-watch/">Apple Watch</a></li><li id="menu-item-104215" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104215"><a href="https://knowtechie.com/tag/airpods/">Airpods</a></li><li id="menu-item-104220" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104220"><a href="https://knowtechie.com/tag/ipad/">iPad</a></li><li id="menu-item-104300" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104300"><a href="https://knowtechie.com/tag/smartphones/">Smartphones</a></li><li id="menu-item-104310" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104310"><a href="https://knowtechie.com/tag/audio/">Audio</a></li><li id="menu-item-104321" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104321"><a href="https://knowtechie.com/tag/gadgets">More gadgets</a></li></ul></li><li id="menu-item-44922" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-44922"><a href="https://knowtechie.com/category/gametechie/">#GameTechie</a><ul class="sub-menu"><li id="menu-item-104195" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104195"><a href="https://knowtechie.com/tag/nintendo-switch/">Nintendo Switch</a></li><li id="menu-item-104196" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104196"><a href="https://knowtechie.com/tag/xbox-one/">Xbox One</a></li><li id="menu-item-104197" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104197"><a href="https://knowtechie.com/tag/playstation-4/">PlayStation 4</a></li><li id="menu-item-104198" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104198"><a href="https://knowtechie.com/tag/sony/">Sony</a></li><li id="menu-item-104199" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104199"><a href="https://knowtechie.com/tag/microsoft">Microsoft</a></li><li id="menu-item-104200" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104200"><a href="https://knowtechie.com/tag/nintendo">Nintendo</a></li><li id="menu-item-112860" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112860"><a href="https://knowtechie.com/tag/pc">PC</a></li></ul></li><li id="menu-item-94286" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94286"><a href="https://knowtechie.com/category/how-to/">How-To</a></li><li id="menu-item-44923" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-44923"><a href="https://knowtechie.com/category/apps/">Apps</a><ul class="sub-menu"><li id="menu-item-104186" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104186"><a href="https://knowtechie.com/tag/ios">iOS</a></li><li id="menu-item-104187" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104187"><a href="https://knowtechie.com/android">Android</a></li><li id="menu-item-104204" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104204"><a href="https://knowtechie.com/tag/windows-10/">Windows 10</a></li><li id="menu-item-104205" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104205"><a href="https://knowtechie.com/tag/mac">Mac</a></li></ul></li><li id="menu-item-44924" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-44924"><a href="https://knowtechie.com/category/tech/">Tech</a><ul class="sub-menu"><li id="menu-item-104222" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104222"><a href="https://knowtechie.com/tag/gadgets/">Gadgets</a></li><li id="menu-item-104216" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104216"><a href="https://knowtechie.com/tag/kickstarter/">Kickstarter</a></li><li id="menu-item-104217" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104217"><a href="https://knowtechie.com/tag/indiegogo/">Indiegogo</a></li><li id="menu-item-104218" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104218"><a href="https://knowtechie.com/tag/dronetechie/">#DroneTechie</a></li><li id="menu-item-104289" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104289"><a href="https://knowtechie.com/tag/security/">Security</a></li><li id="menu-item-104299" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104299"><a href="https://knowtechie.com/tag/pc/">PC</a></li><li id="menu-item-104308" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104308"><a href="https://knowtechie.com/tag/pc-hardware/">PC Hardware</a></li><li id="menu-item-104309" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104309"><a href="https://knowtechie.com/tag/vapetechie/">#VapeTechie</a></li><li id="menu-item-104313" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104313"><a href="https://knowtechie.com/tag/bluetooth/">Bluetooth</a></li><li id="menu-item-104314" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104314"><a href="https://knowtechie.com/tag/software/">Software</a></li><li id="menu-item-104315" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104315"><a href="https://knowtechie.com/tag/privacy/">Privacy</a></li><li id="menu-item-104325" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104325"><a href="https://knowtechie.com/tag/ai/">AI</a></li><li id="menu-item-104327" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104327"><a href="https://knowtechie.com/tag/crypto/">Crypto</a></li><li id="menu-item-104328" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104328"><a href="https://knowtechie.com/tag/vr/">VR</a></li></ul></li><li id="menu-item-44925" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-44925"><a href="https://knowtechie.com/category/mobile/">Mobile</a><ul class="sub-menu"><li id="menu-item-104209" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104209"><a href="https://knowtechie.com/tag/apps-2/">Apps</a></li><li id="menu-item-104210" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104210"><a href="https://knowtechie.com/tag/samsung/">Samsung</a></li><li id="menu-item-104291" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104291"><a href="https://knowtechie.com/tag/iphone/">iPhone</a></li><li id="menu-item-104304" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104304"><a href="https://knowtechie.com/tag/smartphone/">Smartphones</a></li></ul></li><li id="menu-item-44926" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-44926"><a href="https://knowtechie.com/category/internet/">Internet</a><ul class="sub-menu"><li id="menu-item-104290" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-104290"><a href="https://knowtechie.com/tag/social/">Social</a><ul class="sub-menu"><li id="menu-item-104301" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104301"><a href="https://knowtechie.com/tag/youtube/">YouTube</a></li><li id="menu-item-104307" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104307"><a href="https://knowtechie.com/tag/twitter/">Twitter</a></li><li id="menu-item-104306" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104306"><a href="https://knowtechie.com/tag/instagram/">Instagram</a></li><li id="menu-item-104326" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104326"><a href="https://knowtechie.com/tag/snapchat/">Snapchat</a></li></ul></li></ul></li><li id="menu-item-44930" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44930"><a href="https://knowtechie.com/category/deals/">Deals</a></li></ul></div> </nav></div><div id="mvp-fly-soc-wrap"> <span class="mvp-fly-soc-head">Connect with us</span><ul class="mvp-fly-soc-list left relative"><li><a href="https://facebook.com/knowtechie" target="_blank" class="fa fa-facebook-official fa-2"></a></li><li><a href="https://twitter.com/knowtechie" target="_blank" class="fa fa-twitter fa-2"></a></li><li><a href="https://www.pinterest.com/KnowTechie/" target="_blank" class="fa fa-pinterest-p fa-2"></a></li><li><a href="https://www.instagram.com/knowtechie/" target="_blank" class="fa fa-instagram fa-2"></a></li><li><a href="https://plus.google.com/+KnowTechiePlus" target="_blank" class="fa fa-google-plus fa-2"></a></li><li><a href="https://www.youtube.com/channel/UCjpgYyUblbKvNtElLOFi2jw" target="_blank" class="fa fa-youtube-play fa-2"></a></li></ul></div></div><div id="mvp-site" class="left relative"><div id="mvp-search-wrap"><div id="mvp-search-box"><form method="get" id="searchform" action="https://knowtechie.com/"> <input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' /> <input type="hidden" id="searchsubmit" value="Search" /></form></div><div class="mvp-search-but-wrap mvp-search-click"> <span></span> <span></span></div></div> <header id="mvp-top-head-wrap"> <nav id="mvp-main-nav-wrap"><div id="mvp-top-nav-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-top-nav-cont" class="left relative"><div class="mvp-top-nav-right-out relative"><div class="mvp-top-nav-right-in"><div id="mvp-top-nav-left" class="left relative"><div class="mvp-top-nav-left-out relative"><div class="mvp-top-nav-menu-but left relative"><div class="mvp-fly-but-wrap mvp-fly-but-click left relative"> <span></span> <span></span> <span></span> <span></span></div></div><div class="mvp-top-nav-left-in"><div id="mvp-top-nav-logo" class="left relative" itemscope itemtype="http://schema.org/Organization"> <a itemprop="url" href="https://knowtechie.com/"><img itemprop="logo" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2017/03/logo-pixlr-1.png" alt="KnowTechie" data-rjs="2" /></a><h2 class="mvp-logo-title">KnowTechie</h2></div></div></div></div></div><div id="mvp-top-nav-right" class="right relative"><div id="mvp-top-nav-soc" class="left relative"> <a href="https://www.youtube.com/channel/UCjpgYyUblbKvNtElLOFi2jw" target="_blank"><span class="mvp-nav-soc-but fa fa-youtube fa-2"></span></a> <a href="https://www.instagram.com/knowtechie/" target="_blank"><span class="mvp-nav-soc-but fa fa-instagram fa-2"></span></a> <a href="https://twitter.com/knowtechie" target="_blank"><span class="mvp-nav-soc-but fa fa-twitter fa-2"></span></a> <a href="https://facebook.com/knowtechie" target="_blank"><span class="mvp-nav-soc-but fa fa-facebook-official fa-2"></span></a> <span class="mvp-nav-soc-head">Connect with us</span></div> <span class="mvp-nav-search-but fa fa-search fa-2 mvp-search-click"></span></div></div></div></div></div><div id="mvp-bot-nav-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-bot-nav-cont" class="left"><div class="mvp-bot-nav-out"><div class="mvp-fly-but-wrap mvp-fly-but-click left relative"> <span></span> <span></span> <span></span> <span></span></div><div class="mvp-bot-nav-in"><div id="mvp-nav-menu" class="left"><div class="menu-knowtechie-top-menu-container"><ul id="menu-knowtechie-top-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-44918"><a href="https://knowtechie.com/category/news/">News</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104190"><a href="https://knowtechie.com/tag/gametechie">#GameTechie</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104191"><a href="https://knowtechie.com/tag/google/">Google</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104192"><a href="https://knowtechie.com/tag/android/">Android</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104193"><a href="https://knowtechie.com/tag/ios/">iOS</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104194"><a href="https://knowtechie.com/tag/facebook/">Facebook</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104202"><a href="https://knowtechie.com/tag/amazon/">Amazon</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104203"><a href="https://knowtechie.com/tag/apple">Apple</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104288"><a href="https://knowtechie.com/tag/gadgets/">Gadgets</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104298"><a href="https://knowtechie.com/tag/microsoft/">Microsoft</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104302"><a href="https://knowtechie.com/tag/wtf/">WTF</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44920"><a href="https://knowtechie.com/category/reviews/">Reviews</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-44921"><a href="https://knowtechie.com/category/gadgets/">Gadgets</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104214"><a href="https://knowtechie.com/tag/apple-watch/">Apple Watch</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104215"><a href="https://knowtechie.com/tag/airpods/">Airpods</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104220"><a href="https://knowtechie.com/tag/ipad/">iPad</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104300"><a href="https://knowtechie.com/tag/smartphones/">Smartphones</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104310"><a href="https://knowtechie.com/tag/audio/">Audio</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104321"><a href="https://knowtechie.com/tag/gadgets">More gadgets</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-44922"><a href="https://knowtechie.com/category/gametechie/">#GameTechie</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104195"><a href="https://knowtechie.com/tag/nintendo-switch/">Nintendo Switch</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104196"><a href="https://knowtechie.com/tag/xbox-one/">Xbox One</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104197"><a href="https://knowtechie.com/tag/playstation-4/">PlayStation 4</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104198"><a href="https://knowtechie.com/tag/sony/">Sony</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104199"><a href="https://knowtechie.com/tag/microsoft">Microsoft</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104200"><a href="https://knowtechie.com/tag/nintendo">Nintendo</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112860"><a href="https://knowtechie.com/tag/pc">PC</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94286"><a href="https://knowtechie.com/category/how-to/">How-To</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-44923"><a href="https://knowtechie.com/category/apps/">Apps</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104186"><a href="https://knowtechie.com/tag/ios">iOS</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104187"><a href="https://knowtechie.com/android">Android</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104204"><a href="https://knowtechie.com/tag/windows-10/">Windows 10</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104205"><a href="https://knowtechie.com/tag/mac">Mac</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-44924"><a href="https://knowtechie.com/category/tech/">Tech</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104222"><a href="https://knowtechie.com/tag/gadgets/">Gadgets</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104216"><a href="https://knowtechie.com/tag/kickstarter/">Kickstarter</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104217"><a href="https://knowtechie.com/tag/indiegogo/">Indiegogo</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104218"><a href="https://knowtechie.com/tag/dronetechie/">#DroneTechie</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104289"><a href="https://knowtechie.com/tag/security/">Security</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104299"><a href="https://knowtechie.com/tag/pc/">PC</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104308"><a href="https://knowtechie.com/tag/pc-hardware/">PC Hardware</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104309"><a href="https://knowtechie.com/tag/vapetechie/">#VapeTechie</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104313"><a href="https://knowtechie.com/tag/bluetooth/">Bluetooth</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104314"><a href="https://knowtechie.com/tag/software/">Software</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104315"><a href="https://knowtechie.com/tag/privacy/">Privacy</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104325"><a href="https://knowtechie.com/tag/ai/">AI</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104327"><a href="https://knowtechie.com/tag/crypto/">Crypto</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104328"><a href="https://knowtechie.com/tag/vr/">VR</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-44925"><a href="https://knowtechie.com/category/mobile/">Mobile</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104209"><a href="https://knowtechie.com/tag/apps-2/">Apps</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104210"><a href="https://knowtechie.com/tag/samsung/">Samsung</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104291"><a href="https://knowtechie.com/tag/iphone/">iPhone</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104304"><a href="https://knowtechie.com/tag/smartphone/">Smartphones</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-44926"><a href="https://knowtechie.com/category/internet/">Internet</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-104290"><a href="https://knowtechie.com/tag/social/">Social</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104301"><a href="https://knowtechie.com/tag/youtube/">YouTube</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104307"><a href="https://knowtechie.com/tag/twitter/">Twitter</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104306"><a href="https://knowtechie.com/tag/instagram/">Instagram</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104326"><a href="https://knowtechie.com/tag/snapchat/">Snapchat</a></li></ul></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44930"><a href="https://knowtechie.com/category/deals/">Deals</a></li></ul></div></div></div></div></div></div></div> </nav> </header> <main id="mvp-main-wrap" class="left relative"><div id="mvp-leader-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-leader-cont"> <ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-5956380843928535"
data-ad-slot="1804298207"
data-ad-format="auto"></ins></div></div></div><div id="mvp-main-body-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-main-body" class="left relative"><article id="mvp-article-wrap" class="post-127111 post type-post status-publish format-standard has-post-thumbnail hentry category-apple category-gadgets tag-apple tag-gadgets tag-macbook tag-macbook-air tag-macbook-pro tag-news" itemscope itemtype="http://schema.org/NewsArticle"><div class="mvp-sec-pad left relative"><meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://knowtechie.com/which-macbook-should-i-buy-for-college/"/><div class="mvp-post-content-out relative"><div class="mvp-post-content-in"><div id="mvp-post-content" class="left relative"><div class="mvp-content-box"><div id="mvp-article-head2" class="left relative"><h3 class="mvp-post-cat left"><a class="mvp-post-cat-link" href="https://knowtechie.com/category/apple/"><span class="mvp-post-cat left">Apple</span></a></h3><h1 class="mvp-post-title left entry-title" itemprop="headline">Which MacBook should I buy for college?</h1> <span class="mvp-post-excerpt left"><p>Students need a reliable laptop for school, and MacBooks deliver.</p> </span><div class="mvp-author-info-wrap left relative"><ul class="mvp-author-info-list left relative"><li class="mvp-author-info-thumb"> <img alt='' src='https://secure.gravatar.com/avatar/0fb7845ad2813665b192f1347d9f266f' srcset='https://secure.gravatar.com/avatar/0fb7845ad2813665b192f1347d9f266f 2x' class='avatar avatar-46 photo' height='46' width='46' loading='lazy'/></li><li class="mvp-author-info-name" itemprop="author" itemscope itemtype="https://schema.org/Person"><p>by</p> <span class="author-name vcard fn author" itemprop="name"><a href="https://knowtechie.com/author/joe-rice-jones/" title="Posts by Joe Rice-Jones" rel="author">Joe Rice-Jones</a></span></li><li class="mvp-author-info-twit"> <a href="https://twitter.com/iWalkingCorpse" class="mvp-twit-but" target="_blank"><span class="mvp-author-info-twit-but"><i class="fa fa-twitter fa-2"></i></span></a></li><li class="mvp-author-info-date"> <span class="mvp-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2020-08-20">August 20, 2020</time></span><meta itemprop="dateModified" content="2020-08-20"/></li></ul></div></div><div id="mvp-post-feat-img" class="left relative" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"> <img width="1600" height="900" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/macbook-air-on-table.jpg" class="attachment- size- wp-post-image" alt="macbook air on table" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/macbook-air-on-table.jpg 1600w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/macbook-air-on-table-300x169.jpg 300w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/macbook-air-on-table-1024x576.jpg 1024w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/macbook-air-on-table-768x432.jpg 768w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/macbook-air-on-table-1536x864.jpg 1536w" sizes="(max-width: 1600px) 100vw, 1600px" /><meta itemprop="url" content="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/macbook-air-on-table-1000x600.jpg"><meta itemprop="width" content="1000"><meta itemprop="height" content="600"></div> <span class="mvp-feat-caption">Image: Unsplash</span><div class="mvp-post-soc-out relative"><div id="mvp-post-soc-wrap" class="left relative"><ul class="mvp-post-soc-list left relative"> <a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://knowtechie.com/which-macbook-should-i-buy-for-college/&amp;t=Which MacBook should I buy for college?', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><li class="mvp-post-soc-fb"> <i class="fa fa-2 fa-facebook" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://twitter.com/share?text=Which MacBook should I buy for college? -&amp;url=https://knowtechie.com/which-macbook-should-i-buy-for-college/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><li class="mvp-post-soc-twit"> <i class="fa fa-2 fa-twitter" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://knowtechie.com/which-macbook-should-i-buy-for-college/&amp;media=https://knowtechie.com/wp-content/uploads/2020/08/macbook-air-on-table-1000x600.jpg&amp;description=Which MacBook should I buy for college?', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><li class="mvp-post-soc-pin"> <i class="fa fa-2 fa-pinterest-p" aria-hidden="true"></i></li> </a> <a href="mailto:?subject=Which MacBook should I buy for college?&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://knowtechie.com/which-macbook-should-i-buy-for-college/"><li class="mvp-post-soc-email"> <i class="fa fa-2 fa-envelope" aria-hidden="true"></i></li> </a> <a href="#disqus_thread"><li class="mvp-post-soc-com mvp-com-click"> <i class="fa fa-2 fa-commenting" aria-hidden="true"></i></li> </a></ul></div><div class="mvp-post-soc-in"><div id="mvp-content-main" class="left relative" itemprop="articleBody"><p>It&#8217;s no question that going to college this fall will be far different than in recent years. With on-campus instruction at a minimum, that means you need a capable computer with a webcam. Normally, we&#8217;d suggest buying a desktop PC and a USB webcam, but the business world bought <a href="https://knowtechie.com/the-5-best-external-hd-webcams-for-under-100/">all the webcams</a> already.</p><p><a href="/tag/apple">Apple</a> has long been associated with <a href="https://www.apple.com/us-hed/shop/back-to-school">higher education</a>, with solidly-built devices that minimize the number of disruptions due to driver issues or battery life that plague Windows-based laptops. That&#8217;s why we generally advise that a MacBook is the way to go for college use, but which one?</p><h2>So, which MacBook should I buy for college?</h2><blockquote><p><strong>Short answer:</strong> The <a href="https://amzn.to/2Q9ee2e">MacBook Air</a></p></blockquote><p>Whether your college is still doing on-campus, blended, or fully-remote this year, you&#8217;ll be best served with <a href="https://amzn.to/2Q9ee2e">the MacBook Air</a>. The main reason? The 12-hour battery life, more than enough for a full day of lectures or working from wherever you can find a quiet spot at home. The lower weight doesn&#8217;t hurt it either, and your back will thank you.</p><p>It&#8217;s powered by 10th-gen Intel chips, so you&#8217;ll have the power you need for studying, and fast SSD storage that also makes it less susceptible to data loss while moving around.</p><p>If you really need extra power, the 16-inch MacBook Pro is a good option, with the ability to add a discrete graphics chip and more powerful CPU choices. Expect to pay <a href="https://amzn.to/2E7ZMVx">over $2,000</a> for that additional power though.</p><p><em>What do you think? Do you have a preferred laptop for schoolwork? <em>Let us know down below in the comments or carry the discussion over to our <a href="https://twitter.com/knowtechie">Twitter</a> or <a href="https://facebook.com/knowtechie">Facebook</a></em>.</em></p><h4>Editors&#8217; Recommendations:</h4><ul><li><strong><a href="https://knowtechie.com/which-macbook-charger-do-i-need/">Which MacBook charger do I need?</a></strong></li><li><strong><a href="https://knowtechie.com/how-to-check-the-battery-health-of-your-iphone-ipad-apple-watch-and-macbook/">How to check the battery health of your iPhone, iPad, Apple Watch, and MacBook</a></strong></li><li><strong><a href="https://knowtechie.com/can-the-iphone-11-be-unlocked/">Can the iPhone 11 be unlocked?</a></strong></li><li><strong><a href="https://knowtechie.com/can-your-ipad-pro-charge-an-iphone/">Can your iPad Pro charge an iPhone?</a></strong></li></ul><p><em>Just a heads up, if you buy something through our links, we may get a small share of the sale. It&#8217;s one of the ways we keep the lights on here. <a title="About KnowTechie Deals" href="https://knowtechie.com/disclosure/">Click here</a> for more.</em></p><div class="mvp-post-tags"> <span class="mvp-post-tags-header">Related Topics</span><span itemprop="keywords"><a href="https://knowtechie.com/tag/apple/" rel="tag">Apple</a><a href="https://knowtechie.com/tag/gadgets/" rel="tag">Gadgets</a><a href="https://knowtechie.com/tag/macbook/" rel="tag">MacBook</a><a href="https://knowtechie.com/tag/macbook-air/" rel="tag">MacBook Air</a><a href="https://knowtechie.com/tag/macbook-pro/" rel="tag">Macbook Pro</a><a href="https://knowtechie.com/tag/news/" rel="tag">News</a></span></div><div class="posts-nav-link"></div><div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"> <img src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2017/03/logo-pixlr-1.png"/><meta itemprop="url" content="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2017/03/logo-pixlr-1.png"></div><meta itemprop="name" content="KnowTechie"></div></div><div id="mvp-comments-button" class="left relative mvp-com-click"> <span class="mvp-comment-but-text"><span class="dsq-postid" data-dsqidentifier="127111 https://knowtechie.com/?p=127111">Comments</span></span></div><div id="disqus_thread" class="disqus-thread-127111"></div> <script type="text/javascript">var disqus_shortname = "knowtechie";
        var disqus_title = "Which MacBook should I buy for college?";
        var disqus_url = "https://knowtechie.com/which-macbook-should-i-buy-for-college/";
        var disqus_identifier = "knowtechie-127111";</script> </div></div></div></div></div><div id="mvp-side-wrap" class="relative"> <section id="mvp_tabber_widget-11" class="mvp-side-widget mvp_tabber_widget"><div class="mvp-side-tab-wrap left relative"><div class="mvp-side-tab-top left relative"><ul class="mvp-side-tab-list mvp-col-tabs"><li class="mvp-feat-col-tab"> <a href="#mvp-tab-col1"><span class="mvp-side-tab-head"><i class="fa fa-clock-o" aria-hidden="true"></i> Headlines</span></a></li><li> <a href="#mvp-tab-col2"><span class="mvp-side-tab-head"><i class="fa fa-bolt" aria-hidden="true"></i> Trending</span></a></li><li> <a href="#mvp-tab-col3"><span class="mvp-side-tab-head"><i class="fa fa-play-circle-o" aria-hidden="true"></i> Videos</span></a></li></ul></div><div id="mvp-tab-col1" class="mvp-side-tab-main left relative mvp-tab-col-cont"><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/knowtechie-giveaway-enter-for-your-chance-to-win-this-ravpower-portable-power-station/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/RAVPower-portable-charging-station-1-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="RAVPower portable charging station" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/RAVPower-portable-charging-station-1-80x80.jpg 80w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/RAVPower-portable-charging-station-1-150x150.jpg 150w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/RAVPower-portable-charging-station-1-912x900.jpg 912w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/RAVPower-portable-charging-station-1-550x550.jpg 550w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/RAVPower-portable-charging-station-1-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>Giveaway</h3><h2><a href="https://knowtechie.com/knowtechie-giveaway-enter-for-your-chance-to-win-this-ravpower-portable-power-station/" rel="bookmark">KnowTechie Giveaway: Enter for your chance to win this RAVPower Portable Power Station</a></h2></div></div></div></div><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/microsoft-flight-simulator-is-gorgeous-but-these-glitches-are-something-else/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/04/flight-simulator-2020-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="microsoft flight simulator 2020" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/04/flight-simulator-2020-80x80.jpg 80w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/04/flight-simulator-2020-150x150.jpg 150w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/04/flight-simulator-2020-912x900.jpg 912w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/04/flight-simulator-2020-550x550.jpg 550w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/04/flight-simulator-2020-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>#GameTechie</h3><h2><a href="https://knowtechie.com/microsoft-flight-simulator-is-gorgeous-but-these-glitches-are-something-else/" rel="bookmark">Microsoft Flight Simulator is gorgeous, but these glitches are something else</a></h2></div></div></div></div><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/which-macbook-should-i-buy-for-college/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/macbook-air-on-table-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="macbook air on table" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/macbook-air-on-table-80x80.jpg 80w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/macbook-air-on-table-150x150.jpg 150w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/macbook-air-on-table-912x900.jpg 912w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/macbook-air-on-table-550x550.jpg 550w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/macbook-air-on-table-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>Apple</h3><h2><a href="https://knowtechie.com/which-macbook-should-i-buy-for-college/" rel="bookmark">Which MacBook should I buy for college?</a></h2></div></div></div></div><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/sequel-to-famed-viral-conspiracy-video-quickly-fades-into-the-void-of-nonsensical-obscurity/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/social-media-platforms-on-phone-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/social-media-platforms-on-phone-80x80.jpg 80w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/social-media-platforms-on-phone-150x150.jpg 150w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/social-media-platforms-on-phone-912x900.jpg 912w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/social-media-platforms-on-phone-550x550.jpg 550w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/social-media-platforms-on-phone-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>News</h3><h2><a href="https://knowtechie.com/sequel-to-famed-viral-conspiracy-video-quickly-fades-into-the-void-of-nonsensical-obscurity/" rel="bookmark">Sequel to famed viral conspiracy video quickly fades into the void of nonsensical obscurity</a></h2></div></div></div></div><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/airbnb-bans-all-parties-held-at-its-houses-globally/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2017/11/airbnb-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="airbnb" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2017/11/airbnb-80x80.jpg 80w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2017/11/airbnb-150x150.jpg 150w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2017/11/airbnb-550x550.jpg 550w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2017/11/airbnb-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>News</h3><h2><a href="https://knowtechie.com/airbnb-bans-all-parties-held-at-its-houses-globally/" rel="bookmark">Airbnb bans all parties held at its houses, globally</a></h2></div></div></div></div><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/google-knows-its-latest-android-auto-update-is-a-complete-shit-show/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/google-android-auto-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="android auto in car" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/google-android-auto-80x80.jpg 80w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/google-android-auto-150x150.jpg 150w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/google-android-auto-912x900.jpg 912w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/google-android-auto-550x550.jpg 550w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/google-android-auto-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>Mobile</h3><h2><a href="https://knowtechie.com/google-knows-its-latest-android-auto-update-is-a-complete-shit-show/" rel="bookmark">Google knows its latest Android Auto update is a complete shit show</a></h2></div></div></div></div></div><div id="mvp-tab-col2" class="mvp-side-tab-main left relative mvp-tab-col-cont"><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/knowtechie-giveaway-enter-for-your-chance-to-win-this-ravpower-portable-power-station/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/RAVPower-portable-charging-station-1-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="RAVPower portable charging station" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/RAVPower-portable-charging-station-1-80x80.jpg 80w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/RAVPower-portable-charging-station-1-150x150.jpg 150w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/RAVPower-portable-charging-station-1-912x900.jpg 912w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/RAVPower-portable-charging-station-1-550x550.jpg 550w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/RAVPower-portable-charging-station-1-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>Giveaway</h3><h2><a href="https://knowtechie.com/knowtechie-giveaway-enter-for-your-chance-to-win-this-ravpower-portable-power-station/" rel="bookmark">KnowTechie Giveaway: Enter for your chance to win this RAVPower Portable Power Station</a></h2></div></div></div></div><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/google-introduced-new-android-features/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/google-android-features-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="google android features" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/google-android-features-80x80.jpg 80w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/google-android-features-150x150.jpg 150w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/google-android-features-912x900.jpg 912w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/google-android-features-550x550.jpg 550w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/google-android-features-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><div class="mvp-vid-box-wrap"> <i class="fa fa-2 fa-play" aria-hidden="true"></i></div></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>Android</h3><h2><a href="https://knowtechie.com/google-introduced-new-android-features/" rel="bookmark">Google is rolling out a bunch of new Android features &#8211; check them out here</a></h2></div></div></div></div><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/the-best-new-ios-and-android-apps-to-download-in-august-2020/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/best-apps-august-2020-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="apps on an iphone" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/best-apps-august-2020-80x80.jpg 80w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/best-apps-august-2020-150x150.jpg 150w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/best-apps-august-2020-912x900.jpg 912w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/best-apps-august-2020-550x550.jpg 550w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/best-apps-august-2020-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><div class="mvp-vid-box-wrap"> <i class="fa fa-2 fa-play" aria-hidden="true"></i></div></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>Apps</h3><h2><a href="https://knowtechie.com/the-best-new-ios-and-android-apps-to-download-in-august-2020/" rel="bookmark">The best new iOS and Android apps to download in August 2020</a></h2></div></div></div></div><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/tim-cook-ceo-apple-billionaire/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/10/apple-tim-cook-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="apple&#039;s tim cook standing with an apple logo behind him" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/10/apple-tim-cook-80x80.jpg 80w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/10/apple-tim-cook-150x150.jpg 150w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/10/apple-tim-cook-912x897.jpg 912w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/10/apple-tim-cook-550x550.jpg 550w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/10/apple-tim-cook-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>Apple</h3><h2><a href="https://knowtechie.com/tim-cook-ceo-apple-billionaire/" rel="bookmark">Tim Cook, the CEO of Apple, is now a billionaire &#8211; here’s why that matters </a></h2></div></div></div></div><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/the-five-best-board-games-you-can-play-on-steam/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/07/board-games-kt-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="board games for non-gamers" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/07/board-games-kt-80x80.jpg 80w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/07/board-games-kt-150x150.jpg 150w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/07/board-games-kt-912x900.jpg 912w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/07/board-games-kt-550x550.jpg 550w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/07/board-games-kt-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><div class="mvp-vid-box-wrap"> <i class="fa fa-2 fa-play" aria-hidden="true"></i></div></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>#GameTechie</h3><h2><a href="https://knowtechie.com/the-five-best-board-games-you-can-play-on-steam/" rel="bookmark">The five best board games you can play on Steam</a></h2></div></div></div></div></div><div id="mvp-tab-col3" class="mvp-side-tab-main left relative mvp-tab-col-cont"><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/ive-been-training-for-fall-guys-my-entire-life/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/fall-guys-main-screen-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="fall guys main screen" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/fall-guys-main-screen-80x80.jpg 80w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/fall-guys-main-screen-150x150.jpg 150w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/fall-guys-main-screen-912x900.jpg 912w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/fall-guys-main-screen-550x550.jpg 550w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/fall-guys-main-screen-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><div class="mvp-vid-box-wrap"> <i class="fa fa-2 fa-play" aria-hidden="true"></i></div></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>#GameTechie</h3><h2><a href="https://knowtechie.com/ive-been-training-for-fall-guys-my-entire-life/" rel="bookmark">I&#8217;ve been training for Fall Guys my entire life</a></h2></div></div></div></div><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/someone-has-invented-a-gun-that-can-fire-a-mask-onto-your-face/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/gunmask-firing-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="face mask gun" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/gunmask-firing-80x80.jpg 80w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/gunmask-firing-150x150.jpg 150w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/gunmask-firing-912x903.jpg 912w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/gunmask-firing-550x550.jpg 550w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/gunmask-firing-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><div class="mvp-vid-box-wrap"> <i class="fa fa-2 fa-play" aria-hidden="true"></i></div></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>Gadgets</h3><h2><a href="https://knowtechie.com/someone-has-invented-a-gun-that-can-fire-a-mask-onto-your-face/" rel="bookmark">Someone has invented a gun that can fire a mask onto your face</a></h2></div></div></div></div><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/boeing-747-airplanes-are-still-updated-via-floppy-drive/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/tomek-baginski-U22Xq_QS11g-unsplash-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="boing 747 400 at Heathrow Airport" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/tomek-baginski-U22Xq_QS11g-unsplash-80x80.jpg 80w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/tomek-baginski-U22Xq_QS11g-unsplash-150x150.jpg 150w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/tomek-baginski-U22Xq_QS11g-unsplash-912x900.jpg 912w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/tomek-baginski-U22Xq_QS11g-unsplash-550x550.jpg 550w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/tomek-baginski-U22Xq_QS11g-unsplash-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><div class="mvp-vid-box-wrap"> <i class="fa fa-2 fa-play" aria-hidden="true"></i></div></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>News</h3><h2><a href="https://knowtechie.com/boeing-747-airplanes-are-still-updated-via-floppy-drive/" rel="bookmark">Boeing 747 airplanes are still updated via floppy drive</a></h2></div></div></div></div><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/casecrawler-allows-your-smartphone-to-walk-to-the-nearest-wireless-charger/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/casecrawler-phone-charging-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="casecrawler phone case" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/casecrawler-phone-charging-80x80.jpg 80w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/casecrawler-phone-charging-150x150.jpg 150w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/casecrawler-phone-charging-912x900.jpg 912w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/casecrawler-phone-charging-550x550.jpg 550w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/casecrawler-phone-charging-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><div class="mvp-vid-box-wrap"> <i class="fa fa-2 fa-play" aria-hidden="true"></i></div></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>Gadgets</h3><h2><a href="https://knowtechie.com/casecrawler-allows-your-smartphone-to-walk-to-the-nearest-wireless-charger/" rel="bookmark">Casecrawler allows your smartphone to walk to the nearest wireless charger</a></h2></div></div></div></div><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/google-introduced-new-android-features/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/google-android-features-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="google android features" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/google-android-features-80x80.jpg 80w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/google-android-features-150x150.jpg 150w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/google-android-features-912x900.jpg 912w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/google-android-features-550x550.jpg 550w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/google-android-features-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><div class="mvp-vid-box-wrap"> <i class="fa fa-2 fa-play" aria-hidden="true"></i></div></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>Android</h3><h2><a href="https://knowtechie.com/google-introduced-new-android-features/" rel="bookmark">Google is rolling out a bunch of new Android features &#8211; check them out here</a></h2></div></div></div></div></div></div></section><div class="mvp-widget-ad left relative"> <span class="mvp-ad-label">Advertisement</span> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:inline-block;width:300px;height:600px"
data-ad-client="ca-pub-5956380843928535"
data-ad-slot="2512586079"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div></div> <section id="mvp-more-post-wrap" class="left relative"><h4 class="mvp-sec-head"><span class="mvp-sec-head">More in Apple</span></h4><ul class="mvp-more-post-list left relative"><li> <a href="https://knowtechie.com/which-macbook-charger-do-i-need/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2019/02/macbook-pro-touch-bar-main-400x240.jpg" class="mvp-reg-img wp-post-image" alt="macbook charger macbook pro on table" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2019/02/macbook-pro-touch-bar-main-400x240.jpg 400w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2019/02/macbook-pro-touch-bar-main-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <img width="80" height="80" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2019/02/macbook-pro-touch-bar-main-80x80.jpg" class="mvp-mob-img wp-post-image" alt="macbook charger macbook pro on table" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2019/02/macbook-pro-touch-bar-main-80x80.jpg 80w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2019/02/macbook-pro-touch-bar-main-150x150.jpg 150w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2019/02/macbook-pro-touch-bar-main-912x899.jpg 912w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2019/02/macbook-pro-touch-bar-main-550x550.jpg 550w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2019/02/macbook-pro-touch-bar-main-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></div> </a><div class="mvp-more-post-text left relative"><h2><a href="https://knowtechie.com/which-macbook-charger-do-i-need/" rel="bookmark">Which MacBook charger do I need?</a></h2><p>Everyone knows the chargers that come with your MacBook are not nearly as sturdy...</p></div></li><li> <a href="https://knowtechie.com/apple-tv-subscribers-can-now-get-a-sweet-deal-on-cbs-all-access-and-showtime/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2019/11/apple-tv-plus-on-tv-400x240.jpg" class="mvp-reg-img wp-post-image" alt="apple tv+ on tv" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2019/11/apple-tv-plus-on-tv-400x240.jpg 400w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2019/11/apple-tv-plus-on-tv-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <img width="80" height="80" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2019/11/apple-tv-plus-on-tv-80x80.jpg" class="mvp-mob-img wp-post-image" alt="apple tv+ on tv" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2019/11/apple-tv-plus-on-tv-80x80.jpg 80w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2019/11/apple-tv-plus-on-tv-150x150.jpg 150w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2019/11/apple-tv-plus-on-tv-912x912.jpg 912w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2019/11/apple-tv-plus-on-tv-550x550.jpg 550w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2019/11/apple-tv-plus-on-tv-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></div> </a><div class="mvp-more-post-text left relative"><h2><a href="https://knowtechie.com/apple-tv-subscribers-can-now-get-a-sweet-deal-on-cbs-all-access-and-showtime/" rel="bookmark">This Apple TV+ deal combines Showtime and CBS All Access for just under $10</a></h2><p>I am drowning in subscriptions.</p></div></li><li> <a href="https://knowtechie.com/youll-now-have-a-year-to-decide-if-you-actually-want-applecare/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/applecare-plus-logo-iphone-400x240.jpg" class="mvp-reg-img wp-post-image" alt="applecare+ logo" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/applecare-plus-logo-iphone-400x240.jpg 400w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/applecare-plus-logo-iphone-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <img width="80" height="80" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/applecare-plus-logo-iphone-80x80.jpg" class="mvp-mob-img wp-post-image" alt="applecare+ logo" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/applecare-plus-logo-iphone-80x80.jpg 80w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/applecare-plus-logo-iphone-150x150.jpg 150w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/applecare-plus-logo-iphone-912x900.jpg 912w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/applecare-plus-logo-iphone-550x550.jpg 550w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/08/applecare-plus-logo-iphone-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></div> </a><div class="mvp-more-post-text left relative"><h2><a href="https://knowtechie.com/youll-now-have-a-year-to-decide-if-you-actually-want-applecare/" rel="bookmark">You&#8217;ll now have a year to decide if you actually want AppleCare+</a></h2><p>This is a lot better than the current 60-day window.</p></div></li><li> <a href="https://knowtechie.com/a-new-leak-claims-the-iphone-12-may-arrive-around-october-12/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/03/apple-iphone-apps-400x240.jpg" class="mvp-reg-img wp-post-image" alt="ios apple iphone showing apps on table iphone 11 unlocked" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/03/apple-iphone-apps-400x240.jpg 400w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/03/apple-iphone-apps-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <img width="80" height="80" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/03/apple-iphone-apps-80x80.jpg" class="mvp-mob-img wp-post-image" alt="ios apple iphone showing apps on table iphone 11 unlocked" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/03/apple-iphone-apps-80x80.jpg 80w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/03/apple-iphone-apps-150x150.jpg 150w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/03/apple-iphone-apps-912x900.jpg 912w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/03/apple-iphone-apps-550x550.jpg 550w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/03/apple-iphone-apps-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></div> </a><div class="mvp-more-post-text left relative"><h2><a href="https://knowtechie.com/a-new-leak-claims-the-iphone-12-may-arrive-around-october-12/" rel="bookmark">A new leak claims the iPhone 12 may arrive around October 12</a></h2><p>The iPhone 12 and iPhone 12 Pro might have different release dates.</p></div></li><li> <a href="https://knowtechie.com/a-new-report-sheds-more-light-on-apples-rumored-subscription-bundles/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/05/apple-store-main-400x240.jpg" class="mvp-reg-img wp-post-image" alt="apple store signage" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/05/apple-store-main-400x240.jpg 400w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/05/apple-store-main-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <img width="80" height="80" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/05/apple-store-main-80x80.jpg" class="mvp-mob-img wp-post-image" alt="apple store signage" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/05/apple-store-main-80x80.jpg 80w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/05/apple-store-main-150x150.jpg 150w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/05/apple-store-main-912x900.jpg 912w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/05/apple-store-main-550x550.jpg 550w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2020/05/apple-store-main-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></div> </a><div class="mvp-more-post-text left relative"><h2><a href="https://knowtechie.com/a-new-report-sheds-more-light-on-apples-rumored-subscription-bundles/" rel="bookmark">Apple’s rumored subscription bundles are reportedly coming as soon as October</a></h2><p>If you are drowning in subscriptions, bundle options are always nice.</p></div></li><li> <a href="https://knowtechie.com/tim-cook-ceo-apple-billionaire/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/10/apple-tim-cook-400x240.jpg" class="mvp-reg-img wp-post-image" alt="apple&#039;s tim cook standing with an apple logo behind him" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/10/apple-tim-cook-400x240.jpg 400w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/10/apple-tim-cook-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <img width="80" height="80" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/10/apple-tim-cook-80x80.jpg" class="mvp-mob-img wp-post-image" alt="apple&#039;s tim cook standing with an apple logo behind him" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/10/apple-tim-cook-80x80.jpg 80w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/10/apple-tim-cook-150x150.jpg 150w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/10/apple-tim-cook-912x897.jpg 912w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/10/apple-tim-cook-550x550.jpg 550w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/10/apple-tim-cook-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></div> </a><div class="mvp-more-post-text left relative"><h2><a href="https://knowtechie.com/tim-cook-ceo-apple-billionaire/" rel="bookmark">Tim Cook, the CEO of Apple, is now a billionaire &#8211; here’s why that matters </a></h2><p>Really surprised it took this long.</p></div></li><li> <a href="https://knowtechie.com/sorry-the-iphone-12-wont-be-arriving-in-september/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/09/tim-cook-400x240.jpg" class="mvp-reg-img wp-post-image" alt="tim cook apple event gather round 2018" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/09/tim-cook-400x240.jpg 400w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/09/tim-cook-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <img width="80" height="80" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/09/tim-cook-80x80.jpg" class="mvp-mob-img wp-post-image" alt="tim cook apple event gather round 2018" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/09/tim-cook-80x80.jpg 80w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/09/tim-cook-150x150.jpg 150w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/09/tim-cook-550x550.jpg 550w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/09/tim-cook-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></div> </a><div class="mvp-more-post-text left relative"><h2><a href="https://knowtechie.com/sorry-the-iphone-12-wont-be-arriving-in-september/" rel="bookmark">Sorry, the iPhone 12 won&#8217;t be arriving in September</a></h2><p>In news that surprises no one...</p></div></li><li> <a href="https://knowtechie.com/macos-big-sur-vs-catalina-is-it-worth-upgrading/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/06/macos-mojave-9to5mac-400x240.jpg" class="mvp-reg-img wp-post-image" alt="macos mojave" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/06/macos-mojave-9to5mac-400x240.jpg 400w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/06/macos-mojave-9to5mac-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /> <img width="80" height="80" src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/06/macos-mojave-9to5mac-80x80.jpg" class="mvp-mob-img wp-post-image" alt="macos mojave" loading="lazy" srcset="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/06/macos-mojave-9to5mac-80x80.jpg 80w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/06/macos-mojave-9to5mac-150x150.jpg 150w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/06/macos-mojave-9to5mac-550x550.jpg 550w, https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2018/06/macos-mojave-9to5mac-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></div> </a><div class="mvp-more-post-text left relative"><h2><a href="https://knowtechie.com/macos-big-sur-vs-catalina-is-it-worth-upgrading/" rel="bookmark">macOS Big Sur vs Catalina: Is it worth upgrading?</a></h2><p>Wondering if upgrading to macOS Big Sur is worth it? Check our comparison guide...</p></div></li></ul> </section><div id="mvp-prev-next-wrap"><div id="mvp-prev-post-wrap"><div id="mvp-prev-post-arrow" class="relative"> <span class="fa fa-angle-left fa-4" aria-hidden="true"></span></div><div class="mvp-prev-next-text"> <a href="https://knowtechie.com/which-macbook-charger-do-i-need/" rel="prev">Which MacBook charger do I need?</a></div></div></div></div> </article></div></div></div> </main><div id="mvp-foot-ad-wrap" class="left relative"><div class="mvp-main-box-cont"> <ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-5956380843928535"
data-ad-slot="1804298207"
data-ad-format="auto"></ins></div></div> <footer id="mvp-foot-wrap" class="left relative"><div id="mvp-foot-top" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-foot-logo" class="left relative"> <a href="https://knowtechie.com/"><img src="https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/uploads/2019/04/klogo.png" alt="KnowTechie" data-rjs="2" /></a></div><div id="mvp-foot-soc" class="left relative"><ul class="mvp-foot-soc-list left relative"><li><a href="https://facebook.com/knowtechie" target="_blank" class="fa fa-facebook-official fa-2"></a></li><li><a href="https://twitter.com/knowtechie" target="_blank" class="fa fa-twitter fa-2"></a></li><li><a href="https://www.pinterest.com/KnowTechie/" target="_blank" class="fa fa-pinterest-p fa-2"></a></li><li><a href="https://www.instagram.com/knowtechie/" target="_blank" class="fa fa-instagram fa-2"></a></li><li><a href="https://plus.google.com/+KnowTechiePlus" target="_blank" class="fa fa-google-plus fa-2"></a></li><li><a href="https://www.youtube.com/channel/UCjpgYyUblbKvNtElLOFi2jw" target="_blank" class="fa fa-youtube-play fa-2"></a></li></ul></div></div></div><div id="mvp-foot-bot" class="left relative"><div id="mvp-foot-menu-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-foot-menu" class="left relative"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-21799" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-21799"><a href="https://knowtechie.com">Home</a></li><li id="menu-item-23878" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23878"><a href="https://knowtechie.com/about/">About Us</a></li><li id="menu-item-22004" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22004"><a href="https://knowtechie.com/contact/">Contact</a></li><li id="menu-item-45920" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-45920"><a href="https://knowtechie.com/disclosure/">Disclosures</a></li><li id="menu-item-62571" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-62571"><a href="https://knowtechie.com/privacy-policy/">Privacy Policy</a></li></ul></div></div></div></div><div id="mvp-foot-copy-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-foot-copy" class="left relative"><p>Copyright © 2020 KnowTechie / Powered by <a rel='nofollow' href="https://kinsta.com/?kaid=YCKNTMAMNMAR">Kinsta</a></p></div></div></div></div> </footer><div id="mvp-mob-soc-wrap" class="left relative"> <span class="mvp-mob-soc-share-but fa fa-share fa-2 mvp-mob-soc-click" aria-hidden="true"></span><ul class="mvp-mob-soc-list left relative"> <a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://knowtechie.com/which-macbook-should-i-buy-for-college/&amp;t=Which MacBook should I buy for college?', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><li class="mvp-mob-soc-fb"> <i class="fa fa-2 fa-facebook" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://twitter.com/share?text=Which MacBook should I buy for college? -&amp;url=https://knowtechie.com/which-macbook-should-i-buy-for-college/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><li class="mvp-mob-soc-twit"> <i class="fa fa-2 fa-twitter" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://knowtechie.com/which-macbook-should-i-buy-for-college/&amp;media=https://knowtechie.com/wp-content/uploads/2020/08/macbook-air-on-table-1000x600.jpg&amp;description=Which MacBook should I buy for college?', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><li class="mvp-mob-soc-pin"> <i class="fa fa-2 fa-pinterest-p" aria-hidden="true"></i></li> </a> <a href="mailto:?subject=Which MacBook should I buy for college?&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://knowtechie.com/which-macbook-should-i-buy-for-college/"><li class="mvp-mob-soc-email"> <i class="fa fa-2 fa-envelope" aria-hidden="true"></i></li> </a></ul></div></div><div class="mvp-fly-top back-to-top"> <i class="fa fa-angle-up fa-3"></i></div><div class="mvp-fly-fade mvp-fly-but-click"></div>  <script async src="https://www.googletagmanager.com/gtag/js?id=UA-51813050-1"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-51813050-1');</script> <script src="//www.anrdoezrs.net/am/7857194/include/allCj/impressions/page/am.js"></script> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-5956380843928535",
     });</script> <amp-ad width="100vw" height=320
type="adsense"
data-ad-client="ca-pub-5956380843928535"
data-ad-slot="1804298207"
data-auto-format="rspv"
data-full-width><div overflow></div> </amp-ad> <script>window._epn = {campaign: 5337707807};</script><span id="lr-check"></span><div data-theiaStickySidebar-sidebarSelector='"#mvp-side-wrap, #mvp-post-soc-wrap"'
data-theiaStickySidebar-options='{"containerSelector":"","additionalMarginTop":124,"additionalMarginBottom":45,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"stick-to-bottom","disableOnResponsiveLayouts":true}'></div> <script type='text/javascript' id='disqus_count-js-extra'>/*  */
var countVars = {"disqusShortname":"knowtechie"};
/*  */</script> <script type='text/javascript' defer src='https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js' id='disqus_count-js'></script><script type='text/javascript' id='disqus_embed-js-extra'>/*  */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"127111 https:\/\/knowtechie.com\/?p=127111","disqusShortname":"knowtechie","disqusTitle":"Which MacBook should I buy for college?","disqusUrl":"https:\/\/knowtechie.com\/which-macbook-should-i-buy-for-college\/","postId":"127111"};
/*  */</script> <script type='text/javascript' defer src='https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js' id='disqus_embed-js'></script><script type='text/javascript' defer src='https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/plugins/theia-sticky-sidebar/js/theia-sticky-sidebar.js' id='theia-sticky-sidebar/theia-sticky-sidebar.js-js'></script><script type='text/javascript' defer src='https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/plugins/theia-sticky-sidebar/js/main.js' id='theia-sticky-sidebar/main.js-js'></script><script type='text/javascript' defer src='https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/themes/the-league/js/mvpcustom.js' id='mvp-custom-js'></script> <script type='text/javascript' id='mvp-custom-js-after'>jQuery(document).ready(function($) {
	$(window).load(function(){
	var aboveHeight = $("#mvp-top-head-wrap").outerHeight();
	$(window).scroll(function(event){
	    	if ($(window).scrollTop() > aboveHeight){
	    		$("#mvp-top-head-wrap").addClass("mvp-score-up");
			$("#mvp-wallpaper").addClass("mvp-wall-up");
			$("#mvp-post-trend-wrap").addClass("mvp-post-trend-down");
			$(".mvp-fly-top").addClass("mvp-to-top");
	    	} else {
	    		$("#mvp-top-head-wrap").removeClass("mvp-score-up");
			$("#mvp-wallpaper").removeClass("mvp-wall-up");
			$("#mvp-post-trend-wrap").removeClass("mvp-post-trend-down");
	    		$(".mvp-fly-top").removeClass("mvp-to-top");
	    	}
	});
	});
	});
	

	jQuery(document).ready(function($) {
	// Main Menu Dropdown Toggle
	$(".mvp-fly-nav-menu .menu-item-has-children a").click(function(event){
	  event.stopPropagation();
	  location.href = this.href;
  	});

	$(".mvp-fly-nav-menu .menu-item-has-children").click(function(){
    	  $(this).addClass("toggled");
    	  if($(".menu-item-has-children").hasClass("toggled"))
    	  {
    	  $(this).children("ul").toggle();
	  $(".mvp-fly-nav-menu").getNiceScroll().resize();
	  }
	  $(this).toggleClass("tog-minus");
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $(".mvp-fly-nav-menu").niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});
	});
	

	jQuery(document).ready(function($) {
	$(".infinite-content").infinitescroll({
	  navSelector: ".mvp-nav-links",
	  nextSelector: ".mvp-nav-links a:first",
	  itemSelector: ".infinite-post",
	  errorCallback: function(){ $(".mvp-inf-more-but").css("display", "none") }
	});
	$(window).unbind(".infscr");
	$(".mvp-inf-more-but").click(function(){
   		$(".infinite-content").infinitescroll("retrieve");
        	return false;
	});
	$(window).load(function(){
		if ($(".mvp-nav-links a").length) {
			$(".mvp-inf-more-but").css("display","inline-block");
		} else {
			$(".mvp-inf-more-but").css("display","none");
		}
	});
	});</script><script type='text/javascript' defer src='https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/themes/the-league/js/scripts.js' id='clickmag-js'></script><script type='text/javascript' defer src='https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/themes/the-league/js/retina.js' id='retina-js'></script><script type='text/javascript' defer src='https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/themes/the-league/js/flexslider.js' id='flexslider-js'></script><script type='text/javascript' defer src='https://mk0knowtechie1qof48y.kinstacdn.com/wp-content/themes/the-league/js/jquery.infinitescroll.min.js' id='infinitescroll-js'></script><script type='text/javascript' defer src='https://mk0knowtechie1qof48y.kinstacdn.com/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script><script type='text/javascript' defer src='https://mk0knowtechie1qof48y.kinstacdn.com/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script> <script>jQuery(document).ready(function($) {
		$(document).on('click', '.mvp-fly-but-click', function(e){
			console.log('hello2');
			$("#mvp-fly-wrap").toggleClass("mvp-fly-menu");
			$(".mvp-fly-but-wrap").toggleClass("mvp-fly-open");
			$(".mvp-fly-fade").toggleClass("mvp-fly-fade-trans");
		});
	});</script> <script>/* loadCSS. [c]2017 Filament Group, Inc. MIT License */
(function(w){if(!w.loadCSS)w.loadCSS=function(){};var rp=loadCSS.relpreload={};rp.support=function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=false}return function(){return ret}}();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){if(link.addEventListener)link.removeEventListener("load",enableStylesheet);else if(link.attachEvent)link.detachEvent("onload",enableStylesheet);link.setAttribute("onload",null);link.media=finalMedia}if(link.addEventListener)link.addEventListener("load",enableStylesheet);else if(link.attachEvent)link.attachEvent("onload",enableStylesheet);setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3E3)};rp.poly=function(){if(rp.support())return;var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss", true);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener)w.addEventListener("load",function(){rp.poly();w.clearInterval(run)});else if(w.attachEvent)w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}if(typeof exports!=="undefined")exports.loadCSS=loadCSS;else w.loadCSS=loadCSS})(typeof global!=="undefined"?global:this);</script></body></html>