<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8" ><meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" /><link rel="pingback" href="https://knowtechie.com/xmlrpc.php" /><meta property="og:image" content="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6-1000x600.jpg" /><meta name="twitter:image" content="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6-1000x600.jpg" /><meta property="og:type" content="article" /><meta property="og:description" content="Can this compete with the titans that are Final Fantasy Tactics and Fire Emblem?" /><meta name="twitter:card" content="summary"><meta name="twitter:url" content="https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/"><meta name="twitter:title" content="Review: Fell Seal: Arbiter’s Mark will scratch that tactical RPG itch quite well"><meta name="twitter:description" content="Can this compete with the titans that are Final Fantasy Tactics and Fire Emblem?"> <script>function fvmuag(){if(navigator.userAgent.match(/x11.*fox\/54|oid\s4.*xus.*ome\/62|oobot|ighth|tmetr|eadles|ingdo/i))return!1;if(navigator.userAgent.match(/x11.*ome\/75\.0\.3770\.100/i)){var e=screen.width,t=screen.height;if("number"==typeof e&&"number"==typeof t&&862==t&&1367==e)return!1}return!0}</script><script>function loadAsync(e,a){var t=document.createElement("script");t.src=e,null!==a&&(t.readyState?t.onreadystatechange=function(){"loaded"!=t.readyState&&"complete"!=t.readyState||(t.onreadystatechange=null,a())}:t.onload=function(){a()}),document.getElementsByTagName("head")[0].appendChild(t)}</script><title>Review: Fell Seal: Arbiter’s Mark will scratch that tactical RPG itch well</title><meta name="description" content="I’m a big Final Fantasy Tactics fan. When I heard about Fell Seal: Arbiter’s Mark, I knew I had to see if could measure up to the titan."/><link rel="canonical" href="https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Review: Fell Seal: Arbiter’s Mark will scratch that tactical RPG itch quite well" /><meta property="og:description" content="I’m a big Final Fantasy Tactics fan. When I heard about Fell Seal: Arbiter’s Mark, I knew I had to see if could measure up to the titan." /><meta property="og:url" content="https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/" /><meta property="og:site_name" content="KnowTechie" /><meta property="article:publisher" content="https://www.facebook.com/KnowTechie" /><meta property="article:tag" content="Fell Seal: Arbiter’s Mark" /><meta property="article:tag" content="GameTechie" /><meta property="article:tag" content="Reviews" /><meta property="article:tag" content="tactical rpg" /><meta property="article:section" content="#GameTechie" /><meta property="article:published_time" content="2019-09-09T20:57:47+00:00" /><meta property="article:modified_time" content="2019-09-09T20:59:11+00:00" /><meta property="og:updated_time" content="2019-09-09T20:59:11+00:00" /><meta property="fb:app_id" content="706420082767874" /><meta property="og:image" content="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6.jpg" /><meta property="og:image:secure_url" content="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6.jpg" /><meta property="og:image:width" content="1600" /><meta property="og:image:height" content="900" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="I’m a big Final Fantasy Tactics fan. When I heard about Fell Seal: Arbiter’s Mark, I knew I had to see if could measure up to the titan." /><meta name="twitter:title" content="Review: Fell Seal: Arbiter’s Mark will scratch that tactical RPG itch quite well" /><meta name="twitter:site" content="@KnowTechie" /><meta name="twitter:image" content="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6.jpg" /><meta name="twitter:creator" content="@Spriteborne" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://knowtechie.com/#organization","name":"KnowTechie","url":"https://knowtechie.com/","sameAs":["https://www.facebook.com/KnowTechie","https://www.instagram.com/knowtechie/","https://www.youtube.com/channel/UCjpgYyUblbKvNtElLOFi2jw","https://www.pinterest.com/KnowTechie/","https://twitter.com/KnowTechie"],"logo":{"@type":"ImageObject","@id":"https://knowtechie.com/#logo","url":"https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2015/04/LOGO-ICON-KNOW-TECHIE-FINAL01-01-COLOR.png","width":207,"height":195,"caption":"KnowTechie"},"image":{"@id":"https://knowtechie.com/#logo"}},{"@type":"WebSite","@id":"https://knowtechie.com/#website","url":"https://knowtechie.com/","name":"KnowTechie","publisher":{"@id":"https://knowtechie.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://knowtechie.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/#primaryimage","url":"https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6.jpg","width":1600,"height":900,"caption":"fell seal arbiters mark gameplay"},{"@type":"WebPage","@id":"https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/#webpage","url":"https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/","inLanguage":"en-US","name":"Review: Fell Seal: Arbiter\u2019s Mark will scratch that tactical RPG itch well","isPartOf":{"@id":"https://knowtechie.com/#website"},"primaryImageOfPage":{"@id":"https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/#primaryimage"},"datePublished":"2019-09-09T20:57:47+00:00","dateModified":"2019-09-09T20:59:11+00:00","description":"I\u2019m a big Final Fantasy Tactics fan. When I heard about Fell Seal: Arbiter\u2019s Mark, I knew I had to see if could measure up to the titan.","breadcrumb":{"@id":"https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/#breadcrumb"}},{"@type":"BreadcrumbList","@id":"https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://knowtechie.com/","url":"https://knowtechie.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/","url":"https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/","name":"Review: Fell Seal: Arbiter\u2019s Mark will scratch that tactical RPG itch quite well"}}]},{"@type":"NewsArticle","@id":"https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/#article","isPartOf":{"@id":"https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/#webpage"},"author":{"@id":"https://knowtechie.com/#/schema/person/152f98d7262cf87ac8a2927c4a6b1a37"},"headline":"Review: Fell Seal: Arbiter\u2019s Mark will scratch that tactical RPG itch quite well","datePublished":"2019-09-09T20:57:47+00:00","dateModified":"2019-09-09T20:59:11+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/#webpage"},"publisher":{"@id":"https://knowtechie.com/#organization"},"image":{"@id":"https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/#primaryimage"},"keywords":"Fell Seal: Arbiter\u2019s Mark,GameTechie,Reviews,tactical rpg","articleSection":"#GameTechie,Reviews","copyrightYear":"2019","copyrightHolder":{"@id":"https://knowtechie.com#organization"}},{"@type":["Person"],"@id":"https://knowtechie.com/#/schema/person/152f98d7262cf87ac8a2927c4a6b1a37","name":"Jake Vander Ende","image":{"@type":"ImageObject","@id":"https://knowtechie.com/#authorlogo","url":"https://secure.gravatar.com/avatar/394645da93f90d92705c3da10d32625e","caption":"Jake Vander Ende"},"description":"Jake is a writer and game designer in the suburbs of Philadelphia. He loves action, exploration, building, filling bars, and turning numbers into bigger numbers. Someday he'll release a video game.","sameAs":["https://twitter.com/https://twitter.com/Spriteborne"]}]}</script> <link rel="amphtml" href="https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/amp/" /><meta name="generator" content="AMP for WP 0.9.98.8"/><script>/**
  * based on domready (c) Dustin Diaz 2014 - License MIT
  * https://github.com/ded/domready
  */
advanced_ads_ready = ( function() {
  var fns = [], listener
    , doc = typeof document === 'object' && document
    , hack = doc && doc.documentElement.doScroll
    , domContentLoaded = 'DOMContentLoaded'
    , loaded = doc && (hack ? /^loaded|^c/ : /^loaded|^i|^c/).test(doc.readyState)

  if (!loaded && doc){
    listener = function () {
	  doc.removeEventListener(domContentLoaded, listener)
	  window.removeEventListener( "load", listener );
	  loaded = 1
	  while (listener = fns.shift()) listener()
	}
	  
	doc.addEventListener(domContentLoaded, listener )
	window.addEventListener( 'load', listener );
  }

  return function (fn) {
    loaded ? setTimeout(fn, 0) : fns.push(fn)
  }
} )();</script><link rel='stylesheet' id='mvp-fonts-css'  href='https://fonts.googleapis.com/css?family=Advent+Pro%3A700%7CRoboto%3A300%2C400%2C500%2C700%2C900%7COswald%3A300%2C400%2C700%7CLato%3A300%2C400%2C700%7CWork+Sans%3A200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7COpen+Sans%3A400%2C700%2C800%7CRoboto+Condensed%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CTitillium+Web%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900&#038;subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese' type='text/css' media='all' /><link rel='stylesheet' id='fvm-header-0-css'  href='https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/cache/fvm/1568030027/out/header-aa5d3a69.min.css' type='text/css' media='all' /> <script type='text/javascript' src='https://kt-media-knowtechie.netdna-ssl.com/wp-includes/js/jquery/jquery.js'></script><script type='text/javascript' defer src='https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/cache/fvm/1568030027/out/header-1c1a049f.min.js'></script><script type='text/javascript' defer src='https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script><link rel='https://api.w.org/' href='https://knowtechie.com/wp-json/' /><link rel="alternate" type="application/json+oembed" href="https://knowtechie.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fknowtechie.com%2Freview-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well%2F" /><link rel="alternate" type="text/xml+oembed" href="https://knowtechie.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fknowtechie.com%2Freview-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well%2F&#038;format=xml" /><meta name="msvalidate.01" content="2A9F9F4152194D81E03CB4F0B0AA728E" /> <script type="text/javascript" src="https://code.jquery.com/jquery-2.2.4.min.js"></script> <script>$ = jQuery;</script><style type="text/css">.cb-lr-font-heading { font-family: Open Sans, sans-serif; }.cb-lr-font-p { font-family: Open Sans, sans-serif; }</style><style type="text/css" id="custom-background-css">body.custom-background { background-color: #f4f4f4; }</style> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-5956380843928535",
enable_page_level_ads: true,
});</script> <link rel="icon" href="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2015/04/cropped-LOGO-ICON-KNOW-TECHIE-FINAL01-01-COLOR-32x32.png" sizes="32x32" /><link rel="icon" href="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2015/04/cropped-LOGO-ICON-KNOW-TECHIE-FINAL01-01-COLOR-192x192.png" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2015/04/cropped-LOGO-ICON-KNOW-TECHIE-FINAL01-01-COLOR-180x180.png" /><meta name="msapplication-TileImage" content="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2015/04/cropped-LOGO-ICON-KNOW-TECHIE-FINAL01-01-COLOR-270x270.png" /></head><body class="post-template-default single single-post postid-100689 single-format-standard custom-background"><div id="mvp-fly-wrap"><div id="mvp-fly-menu-top" class="left relative"><div class="mvp-fly-top-out left relative"><div class="mvp-fly-top-in"><div id="mvp-fly-logo" class="left relative"> <a href="https://knowtechie.com/"><img src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2017/03/logo-pixlr-1.png" alt="KnowTechie" data-rjs="2" /></a></div></div><div class="mvp-fly-but-wrap mvp-fly-but-menu mvp-fly-but-click"> <span></span> <span></span> <span></span> <span></span></div></div></div><div id="mvp-fly-menu-wrap"> <nav class="mvp-fly-nav-menu left relative"><div class="menu-knowtechie-top-menu-container"><ul id="menu-knowtechie-top-menu" class="menu"><li id="menu-item-44918" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44918"><a href="https://knowtechie.com/category/news/">News</a></li><li id="menu-item-44920" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-44920"><a href="https://knowtechie.com/category/reviews/">Reviews</a></li><li id="menu-item-44921" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44921"><a href="https://knowtechie.com/category/gadgets/">Gadgets</a></li><li id="menu-item-44922" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-44922"><a href="https://knowtechie.com/category/gametechie/">#GameTechie</a></li><li id="menu-item-94286" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94286"><a href="https://knowtechie.com/category/how-to/">How-To</a></li><li id="menu-item-44923" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44923"><a href="https://knowtechie.com/category/apps/">Apps</a></li><li id="menu-item-44924" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44924"><a href="https://knowtechie.com/category/tech/">Tech</a></li><li id="menu-item-44925" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44925"><a href="https://knowtechie.com/category/mobile/">Mobile</a></li><li id="menu-item-44926" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44926"><a href="https://knowtechie.com/category/internet/">Internet</a></li><li id="menu-item-44927" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44927"><a href="https://knowtechie.com/category/social-media/">Social</a></li><li id="menu-item-44930" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44930"><a href="https://knowtechie.com/category/deals/">Deals</a></li></ul></div> </nav></div><div id="mvp-fly-soc-wrap"> <span class="mvp-fly-soc-head">Connect with us</span><ul class="mvp-fly-soc-list left relative"><li><a href="http://facebook.com/knowtechie" target="_blank" class="fa fa-facebook-official fa-2"></a></li><li><a href="http://twitter.com/knowtechie" target="_blank" class="fa fa-twitter fa-2"></a></li><li><a href="https://www.pinterest.com/KnowTechie/" target="_blank" class="fa fa-pinterest-p fa-2"></a></li><li><a href="https://plus.google.com/+KnowTechiePlus" target="_blank" class="fa fa-google-plus fa-2"></a></li><li><a href="https://www.youtube.com/channel/UCjpgYyUblbKvNtElLOFi2jw" target="_blank" class="fa fa-youtube-play fa-2"></a></li></ul></div></div><div id="mvp-site" class="left relative"><div id="mvp-search-wrap"><div id="mvp-search-box"><form method="get" id="searchform" action="https://knowtechie.com/"> <input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' /> <input type="hidden" id="searchsubmit" value="Search" /></form></div><div class="mvp-search-but-wrap mvp-search-click"> <span></span> <span></span></div></div> <header id="mvp-top-head-wrap"> <nav id="mvp-main-nav-wrap"><div id="mvp-top-nav-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-top-nav-cont" class="left relative"><div class="mvp-top-nav-right-out relative"><div class="mvp-top-nav-right-in"><div id="mvp-top-nav-left" class="left relative"><div class="mvp-top-nav-left-out relative"><div class="mvp-top-nav-menu-but left relative"><div class="mvp-fly-but-wrap mvp-fly-but-click left relative"> <span></span> <span></span> <span></span> <span></span></div></div><div class="mvp-top-nav-left-in"><div id="mvp-top-nav-logo" class="left relative" itemscope itemtype="http://schema.org/Organization"> <a itemprop="url" href="https://knowtechie.com/"><img itemprop="logo" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2017/03/logo-pixlr-1.png" alt="KnowTechie" data-rjs="2" /></a><h2 class="mvp-logo-title">KnowTechie</h2></div></div></div></div></div><div id="mvp-top-nav-right" class="right relative"><div id="mvp-top-nav-soc" class="left relative"> <a href="https://www.youtube.com/channel/UCjpgYyUblbKvNtElLOFi2jw" target="_blank"><span class="mvp-nav-soc-but fa fa-youtube fa-2"></span></a> <a href="http://twitter.com/knowtechie" target="_blank"><span class="mvp-nav-soc-but fa fa-twitter fa-2"></span></a> <a href="http://facebook.com/knowtechie" target="_blank"><span class="mvp-nav-soc-but fa fa-facebook-official fa-2"></span></a> <span class="mvp-nav-soc-head">Connect with us</span></div> <span class="mvp-nav-search-but fa fa-search fa-2 mvp-search-click"></span></div></div></div></div></div><div id="mvp-bot-nav-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-bot-nav-cont" class="left"><div class="mvp-bot-nav-out"><div class="mvp-fly-but-wrap mvp-fly-but-click left relative"> <span></span> <span></span> <span></span> <span></span></div><div class="mvp-bot-nav-in"><div id="mvp-nav-menu" class="left"><div class="menu-knowtechie-top-menu-container"><ul id="menu-knowtechie-top-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44918"><a href="https://knowtechie.com/category/news/">News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-44920"><a href="https://knowtechie.com/category/reviews/">Reviews</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44921"><a href="https://knowtechie.com/category/gadgets/">Gadgets</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-44922"><a href="https://knowtechie.com/category/gametechie/">#GameTechie</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94286"><a href="https://knowtechie.com/category/how-to/">How-To</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44923"><a href="https://knowtechie.com/category/apps/">Apps</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44924"><a href="https://knowtechie.com/category/tech/">Tech</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44925"><a href="https://knowtechie.com/category/mobile/">Mobile</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44926"><a href="https://knowtechie.com/category/internet/">Internet</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44927"><a href="https://knowtechie.com/category/social-media/">Social</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44930"><a href="https://knowtechie.com/category/deals/">Deals</a></li></ul></div></div></div></div></div></div></div> </nav> </header> <main id="mvp-main-wrap" class="left relative"><div id="mvp-leader-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-leader-cont"> <ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-5956380843928535"
data-ad-slot="1804298207"
data-ad-format="auto"></ins></div></div></div><div id="mvp-main-body-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-main-body" class="left relative"><article id="mvp-article-wrap" class="post-100689 post type-post status-publish format-standard has-post-thumbnail hentry category-gametechie category-reviews tag-fell-seal-arbiters-mark tag-gametechie tag-reviews tag-tactical-rpg" itemscope itemtype="http://schema.org/NewsArticle"><div class="mvp-sec-pad left relative"><meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/"/><div class="mvp-post-content-out relative"><div class="mvp-post-content-in"><div id="mvp-post-content" class="left relative"><div class="mvp-content-box"><div id="mvp-article-head2" class="left relative"><h3 class="mvp-post-cat left"><a class="mvp-post-cat-link" href="https://knowtechie.com/category/gametechie/"><span class="mvp-post-cat left">#GameTechie</span></a></h3><h1 class="mvp-post-title left entry-title" itemprop="headline">Review: Fell Seal: Arbiter’s Mark will scratch that tactical RPG itch quite well</h1> <span class="mvp-post-excerpt left"><p>Can this compete with the titans that are Final Fantasy Tactics and Fire Emblem?</p> </span><div class="mvp-author-info-wrap left relative"><ul class="mvp-author-info-list left relative"><li class="mvp-author-info-thumb"> <img alt='' src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src='https://secure.gravatar.com/avatar/394645da93f90d92705c3da10d32625e' srcset="" data-srcset="https://secure.gravatar.com/avatar/394645da93f90d92705c3da10d32625e 2x" class='lazy lazy-hidden avatar avatar-46 photo' height='46' width='46' /><noscript><img alt='' src='https://secure.gravatar.com/avatar/394645da93f90d92705c3da10d32625e' srcset="https://secure.gravatar.com/avatar/394645da93f90d92705c3da10d32625e 2x" class='avatar avatar-46 photo' height='46' width='46' /></noscript></li><li class="mvp-author-info-name" itemprop="author" itemscope itemtype="https://schema.org/Person"><p>by</p> <span class="author-name vcard fn author" itemprop="name"><a href="https://knowtechie.com/author/jake-vander-ende/" title="Posts by Jake Vander Ende" rel="author">Jake Vander Ende</a></span></li><li class="mvp-author-info-twit"> <a href="https://twitter.com/Spriteborne" class="mvp-twit-but" target="_blank"><span class="mvp-author-info-twit-but"><i class="fa fa-twitter fa-2"></i></span></a></li><li class="mvp-author-info-date"> <span class="mvp-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2019-09-09">September 9, 2019</time></span><meta itemprop="dateModified" content="2019-09-09"/></li></ul></div></div><div id="mvp-post-feat-img" class="left relative" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"> <img width="1600" height="900" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6.jpg" class="lazy lazy-hidden attachment- size- wp-post-image" alt="fell seal arbiters mark gameplay" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6.jpg 1600w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6-300x169.jpg 300w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6-768x432.jpg 768w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6-1024x576.jpg 1024w" sizes="(max-width: 1600px) 100vw, 1600px" /><noscript><img width="1600" height="900" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6.jpg" class="attachment- size- wp-post-image" alt="fell seal arbiters mark gameplay" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6.jpg 1600w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6-300x169.jpg 300w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6-768x432.jpg 768w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6-1024x576.jpg 1024w" sizes="(max-width: 1600px) 100vw, 1600px" /></noscript><meta itemprop="url" content="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6-1000x600.jpg"><meta itemprop="width" content="1000"><meta itemprop="height" content="600"></div> <span class="mvp-feat-caption">Image: Jacob Vander Ende / KnowTechie</span><div class="mvp-post-soc-out relative"><div id="mvp-post-soc-wrap" class="left relative"><ul class="mvp-post-soc-list left relative"> <a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/&amp;t=Review: Fell Seal: Arbiter’s Mark will scratch that tactical RPG itch quite well', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><li class="mvp-post-soc-fb"> <i class="fa fa-2 fa-facebook" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://twitter.com/share?text=Review: Fell Seal: Arbiter’s Mark will scratch that tactical RPG itch quite well -&amp;url=https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><li class="mvp-post-soc-twit"> <i class="fa fa-2 fa-twitter" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/&amp;media=https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6-1000x600.jpg&amp;description=Review: Fell Seal: Arbiter’s Mark will scratch that tactical RPG itch quite well', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><li class="mvp-post-soc-pin"> <i class="fa fa-2 fa-pinterest-p" aria-hidden="true"></i></li> </a> <a href="mailto:?subject=Review: Fell Seal: Arbiter’s Mark will scratch that tactical RPG itch quite well&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/"><li class="mvp-post-soc-email"> <i class="fa fa-2 fa-envelope" aria-hidden="true"></i></li> </a> <a href="#disqus_thread"><li class="mvp-post-soc-com mvp-com-click"> <i class="fa fa-2 fa-commenting" aria-hidden="true"></i></li> </a></ul></div><div class="mvp-post-soc-in"><div id="mvp-content-main" class="left relative" itemprop="articleBody"><div id="cb-review-box-100689" class="cb-skin-base lets-review-box-wrap cb-lr-font-p cb-design-1 cb-skin-version-1 cb-no-fi cb-score-type-2 cb-ani-type-1 cb-location-1 cb-clearfix" data-pid="100689" data-format="2" data-type="2" itemscope itemtype="http://schema.org/Review"><meta itemprop="url" content="https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/"><meta itemprop="name" content=""><meta itemprop="description" content=""><span itemprop="author" itemscope itemtype="http://schema.org/Person"><meta itemprop="name" content="Jake Vander Ende"></span><span itemprop="itemReviewed" itemscope itemtype="http://schema.org/Thing"><meta itemprop="name" content=""></span><meta itemprop="datePublished" content="September 9, 2019"><div class="cb-review-block cb-review-pad cb-score-pros cb-clearfix"><div class="cb-pros-cons-block cb-clearfix"><div class="cb-pros"><div class="cb-pros-title cb-lr-font-heading cb-font-header cb-block-header cb-clearfix">The Good</div><div class="cb-pros-cons cb-pro">Giant array of jobs and classes</div><div class="cb-pros-cons cb-pro">Huge customization options</div></div><div class="cb-cons"><div class="cb-cons-title cb-lr-font-heading cb-font-header cb-block-header cb-clearfix">The Bad</div><div class="cb-pros-cons cb-con">The art style is hit or miss, with some bland animations</div><div class="cb-pros-cons cb-con">Story is a pretty slow burn</div></div></div><div class="cb-score-box cb-lr-font-heading cb-font-header" style="background-color: #891b8e; "><div class="cb-score-titles-wrap"><div class="cb-final-score cb-clearfix" itemprop="reviewRating" itemscope itemtype="http://schema.org/Rating"><meta itemprop="worstRating" content="0"><meta itemprop="ratingValue" content="8" /><meta itemprop="bestRating" content="10" />8</div><div class="cb-score-subtitle">Overall</div></div></div></div></div><p>I’m a big <i>Final Fantasy Tactics </i>fan. I love <i>Fire Emblem</i>. When I heard about <i>Fell Seal: Arbiter’s Mark</i>, I knew I had to see if could measure up to the genre titans. Here’s how it went.</p><p><i><a href="https://www.fellseal.com/">Fell Seal: Arbiter’s Mark</a> </i>starts off simply enough. You’re immersed in a fantasy world where a Great War was won long ago by a group of heroes that earned immortality for their trouble. You follow Kyrie, an Arbiter who acts like a deputy for the Immortals, doling out justice across the land. It feels like any fantasy game, really.</p><h2>The first encounter is against a noble, Alphonse, who murders a commoner right in front of you</h2><div id="attachment_101597" style="width: 1610px" class="wp-caption aligncenter"><a href="https://www.fellseal.com/"><img aria-describedby="caption-attachment-101597" class="lazy lazy-hidden wp-image-101597 size-full" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-5.jpg" alt="fell seal arbiters mark gameplay" width="1600" height="900" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-5.jpg 1600w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-5-300x169.jpg 300w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-5-768x432.jpg 768w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-5-1024x576.jpg 1024w" sizes="(max-width: 1600px) 100vw, 1600px" /><noscript><img aria-describedby="caption-attachment-101597" class="wp-image-101597 size-full" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-5.jpg" alt="fell seal arbiters mark gameplay" width="1600" height="900" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-5.jpg 1600w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-5-300x169.jpg 300w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-5-768x432.jpg 768w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-5-1024x576.jpg 1024w" sizes="(max-width: 1600px) 100vw, 1600px" /></noscript></a><p id="caption-attachment-101597" class="wp-caption-text">Image: Jacob Vander Ende / KnowTechie</p></div><p>The story spirals out from there: One of the Immortals is about to retire and pass on their power to a new candidate, Alphonse is somehow involved with corruption on the council, and there is rot within the orders of Arbiters. As far as I got, I didn’t see anything earth-shattering, but it was engaging enough to be worth continuing. I’m invested in knowing what happens next.</p><p>Mechanically, anyone who’s played a tactical RPG knows exactly what to expect from <i>Fell Seal: Arbiter’s Mark</i>. Everything is turn-based, with one unit acting at a time, and all movement and combat happens on a grid. Units have facings, so an attack from the front is not the same as an attack from the side or back, and there are a million and one classes, ability trees, and ways to customize your forces.</p><h2>All of this felt pretty vanilla at first, to me, at first &#8211; Fell Seal: Arbiter’s Mark seemed to just be another tactical RPG</h2><div id="attachment_101596" style="width: 1610px" class="wp-caption aligncenter"><a href="https://www.fellseal.com/"><img aria-describedby="caption-attachment-101596" class="lazy lazy-hidden wp-image-101596 size-full" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-4.jpg" alt="fell seal arbiters mark gameplay" width="1600" height="900" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-4.jpg 1600w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-4-300x169.jpg 300w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-4-768x432.jpg 768w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-4-1024x576.jpg 1024w" sizes="(max-width: 1600px) 100vw, 1600px" /><noscript><img aria-describedby="caption-attachment-101596" class="wp-image-101596 size-full" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-4.jpg" alt="fell seal arbiters mark gameplay" width="1600" height="900" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-4.jpg 1600w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-4-300x169.jpg 300w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-4-768x432.jpg 768w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-4-1024x576.jpg 1024w" sizes="(max-width: 1600px) 100vw, 1600px" /></noscript></a><p id="caption-attachment-101596" class="wp-caption-text">Image: Jacob Vander Ende / KnowTechie</p></div><p>I never really warmed up to the art style &#8211; which I don’t have strong feelings about one way or another &#8211; and the characters are whatever. I kept thinking, “This game is maybe a 6 or 7, I dunno.”</p><p>That changed, however, the more I played. “Just one more battle before I review this one,” I told myself, over and over again. Then I’d level up a class that a new silhouette of an unknown class would pop up and I’d start making new plans for character training.</p><p>Do I want this character to be a Scoundrel who then learns some magic abilities or should I specialize just far enough to unlock the ranged classes? That class uses guns, so do I need one of those? Maybe my mage should learn healing and support magic, but I don’t know, that offensive class looks super powerful. Oh, I definitely need a magic-knight hybrid, but wait this path could be tankier and more defensive and and and &#8211; you get the idea.</p><h2>See, the ability system is extremely similar to Final Fantasy Tactics, one of my favorite games of all time</h2><div id="attachment_101595" style="width: 1610px" class="wp-caption aligncenter"><a href="https://www.fellseal.com/"><img aria-describedby="caption-attachment-101595" class="lazy lazy-hidden wp-image-101595 size-full" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-3.jpg" alt="fell seal arbiters mark gameplay" width="1600" height="900" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-3.jpg 1600w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-3-300x169.jpg 300w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-3-768x432.jpg 768w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-3-1024x576.jpg 1024w" sizes="(max-width: 1600px) 100vw, 1600px" /><noscript><img aria-describedby="caption-attachment-101595" class="wp-image-101595 size-full" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-3.jpg" alt="fell seal arbiters mark gameplay" width="1600" height="900" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-3.jpg 1600w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-3-300x169.jpg 300w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-3-768x432.jpg 768w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-3-1024x576.jpg 1024w" sizes="(max-width: 1600px) 100vw, 1600px" /></noscript></a><p id="caption-attachment-101595" class="wp-caption-text">Image: Jacob Vander Ende / KnowTechie</p></div><p>Whatever class you have assigned for a character gives that character the active skills and passive skills from that class (e.g. the Wizard gets Elementalism for damage-dealing spells, Smart Casting so those spells only hit enemies even when allies are in the blast radius, and Boon which grants a guaranteed critical hit after dealing a finishing blow).</p><p>Beyond that, you can assign one more active category from another class, two passives from any classes, and a counterattack from any class. As a result, you’ll find yourself looking into every class thinking, “If I could <i>that </i>ability and pair it with <i>that </i>ability, that might be super strong. Hmm, I wonder how long I can level this class before I can do such and such.” It’s an <i>excellent </i>feedback loop and I haven’t seen anything this fully fleshed-out in a long, long time.</p><h2>At this point, I can wholeheartedly recommend Fell Seal: Arbiter’s Mark to anyone who loves tactical RPGs</h2><div id="attachment_101594" style="width: 1610px" class="wp-caption aligncenter"><a href="https://www.fellseal.com/"><img aria-describedby="caption-attachment-101594" class="lazy lazy-hidden wp-image-101594 size-full" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-2.jpg" alt="fell seal arbiters mark gameplay" width="1600" height="900" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-2.jpg 1600w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-2-300x169.jpg 300w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-2-768x432.jpg 768w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-2-1024x576.jpg 1024w" sizes="(max-width: 1600px) 100vw, 1600px" /><noscript><img aria-describedby="caption-attachment-101594" class="wp-image-101594 size-full" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-2.jpg" alt="fell seal arbiters mark gameplay" width="1600" height="900" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-2.jpg 1600w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-2-300x169.jpg 300w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-2-768x432.jpg 768w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-2-1024x576.jpg 1024w" sizes="(max-width: 1600px) 100vw, 1600px" /></noscript></a><p id="caption-attachment-101594" class="wp-caption-text">Image: Jacob Vander Ende / KnowTechie</p></div><p>It lacks the budget of the AAA giants, but what it does offer, it accomplishes very well. The hooks it gets into you are insidiously good and if you’re like me you’ll find yourself spending just as much time in battle as you spend between battles planning your next foray into adventure.</p><p>There’s a lot to chew on here and it’s all well-balanced and engaging, which is way more of a make-or-break point in strategy games for me than art style, story quality, or any other presentation characteristics.</p><div id="attachment_101593" style="width: 1610px" class="wp-caption aligncenter"><a href="https://www.fellseal.com/"><img aria-describedby="caption-attachment-101593" class="lazy lazy-hidden wp-image-101593 size-full" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-1.jpg" alt="fell seal arbiters mark gameplay" width="1600" height="900" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-1.jpg 1600w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-1-300x169.jpg 300w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-1-768x432.jpg 768w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-1-1024x576.jpg 1024w" sizes="(max-width: 1600px) 100vw, 1600px" /><noscript><img aria-describedby="caption-attachment-101593" class="wp-image-101593 size-full" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-1.jpg" alt="fell seal arbiters mark gameplay" width="1600" height="900" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-1.jpg 1600w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-1-300x169.jpg 300w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-1-768x432.jpg 768w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-1-1024x576.jpg 1024w" sizes="(max-width: 1600px) 100vw, 1600px" /></noscript></a><p id="caption-attachment-101593" class="wp-caption-text">Image: Jacob Vander Ende / KnowTechie</p></div><p>I think my only straightforward complaint is that on the Nintendo Switch version, where this was reviewed, you can’t navigate the battlefield with the analog stick: you’re stuck using the d-pad, which is awkward for its own hardware reasons, and made doubly challenging by being shifted 45-degrees to map onto the isometric field.</p><p>Overall, <a href="https://www.fellseal.com/"><i>Fell Seal: Arbiter’s Mark </i></a>is a rock-solid tactical RPG. The story and art aren’t life-changing, but the guts of this game are extremely well done and it’s easily worth your time if you’re a genre fan.</p><p><i>Jake reviewed Fell Seal: Arbiter’s Mark on Nintendo Switch with a review code from the developers. It is available now on Nintendo Switch, PlayStation 4, Windows, Mac, and Linux. </i></p><p><em>Curious what our scores mean? Find out more in our comprehensive guide to <a href="https://knowtechie.com/knowtechie-how-we-score-game-reviews/">Understanding KnowTechie&#8217;s Game Review Scoring</a>.</em></p><h4>Editors&#8217; Recommendations:</h4><ul><li><a href="https://knowtechie.com/here-are-the-best-games-of-the-show-from-pax-west-2019/">Here are the best games of the show from PAX West 2019</a></li><li><a href="https://knowtechie.com/review-rad-an-80s-retro-apocalyptic-foray-into-mutant-action/">Review: RAD &#8211; an 80s retro-apocalyptic foray into mutant action</a></li><li><a href="https://knowtechie.com/psa-youve-been-mislabeling-one-of-the-playstation-controller-buttons-since-forever/">PSA: You&#8217;ve been mislabeling one of the PlayStation controller buttons since forever</a></li><li><a href="https://knowtechie.com/doom-bone-vodka-will-get-you-demon-drunk-on-your-way-to-hell/">Doom Bone Vodka will get you demon drunk on your way to hell</a></li></ul><div id="cb-review-box-100689" class="cb-skin-base lets-review-box-wrap cb-lr-font-p cb-design-1 cb-skin-version-1 cb-no-fi cb-score-type-2 cb-ani-type-1 cb-location-1 cb-clearfix" data-pid="100689" data-format="2" data-type="2" itemscope itemtype="http://schema.org/Review"><meta itemprop="url" content="https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/"><meta itemprop="name" content=""><meta itemprop="description" content=""><span itemprop="author" itemscope itemtype="http://schema.org/Person"><meta itemprop="name" content="Jake Vander Ende"></span><span itemprop="itemReviewed" itemscope itemtype="http://schema.org/Thing"><meta itemprop="name" content=""></span><meta itemprop="datePublished" content="September 9, 2019"><div class="cb-review-block cb-review-pad cb-score-pros cb-clearfix"><div class="cb-pros-cons-block cb-clearfix"><div class="cb-pros"><div class="cb-pros-title cb-lr-font-heading cb-font-header cb-block-header cb-clearfix">The Good</div><div class="cb-pros-cons cb-pro">Giant array of jobs and classes</div><div class="cb-pros-cons cb-pro">Huge customization options</div></div><div class="cb-cons"><div class="cb-cons-title cb-lr-font-heading cb-font-header cb-block-header cb-clearfix">The Bad</div><div class="cb-pros-cons cb-con">The art style is hit or miss, with some bland animations</div><div class="cb-pros-cons cb-con">Story is a pretty slow burn</div></div></div><div class="cb-score-box cb-lr-font-heading cb-font-header" style="background-color: #891b8e; "><div class="cb-score-titles-wrap"><div class="cb-final-score cb-clearfix" itemprop="reviewRating" itemscope itemtype="http://schema.org/Rating"><meta itemprop="worstRating" content="0"><meta itemprop="ratingValue" content="8" /><meta itemprop="bestRating" content="10" />8</div><div class="cb-score-subtitle">Overall</div></div></div></div></div><div class="knowt-after-content" id="knowt-1548925294"><div id="ld-8042-281"></div><script>(function(w,d,s,i){w.ldAdInit=w.ldAdInit||[];w.ldAdInit.push({slot:11244522344760678,size:[0, 0],id:"ld-8042-281"});if(!d.getElementById(i)){var j=d.createElement(s),p=d.getElementsByTagName(s)[0];j.async=true;j.src="//cdn2.lockerdomecdn.com/_js/ajs.js";j.id=i;p.parentNode.insertBefore(j,p);}})(window,document,"script","ld-ajs");</script></div><div class="mvp-post-tags"> <span class="mvp-post-tags-header">Related Topics</span><span itemprop="keywords"><a href="https://knowtechie.com/tag/fell-seal-arbiters-mark/" rel="tag">Fell Seal: Arbiter’s Mark</a><a href="https://knowtechie.com/tag/gametechie/" rel="tag">GameTechie</a><a href="https://knowtechie.com/tag/reviews/" rel="tag">Reviews</a><a href="https://knowtechie.com/tag/tactical-rpg/" rel="tag">tactical rpg</a></span></div><div class="posts-nav-link"></div><div id="mvp-author-box-wrap" class="left relative"><div class="mvp-author-box-out right relative"><div id="mvp-author-box-img" class="left relative"> <img alt='' src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src='https://secure.gravatar.com/avatar/394645da93f90d92705c3da10d32625e' srcset="" data-srcset="https://secure.gravatar.com/avatar/394645da93f90d92705c3da10d32625e 2x" class='lazy lazy-hidden avatar avatar-60 photo' height='60' width='60' /><noscript><img alt='' src='https://secure.gravatar.com/avatar/394645da93f90d92705c3da10d32625e' srcset="https://secure.gravatar.com/avatar/394645da93f90d92705c3da10d32625e 2x" class='avatar avatar-60 photo' height='60' width='60' /></noscript></div><div class="mvp-author-box-in"><div id="mvp-author-box-head" class="left relative"> <span class="mvp-author-box-name left relative"><a href="https://knowtechie.com/author/jake-vander-ende/" title="Posts by Jake Vander Ende" rel="author">Jake Vander Ende</a></span><div id="mvp-author-box-soc-wrap" class="left relative"> <a href="https://twitter.com/Spriteborne" alt="Twitter" target="_blank"><span class="mvp-author-box-soc fa fa-twitter-square fa-2"></span></a></div></div></div></div><div id="mvp-author-box-text" class="left relative"><p>Jake is a writer and game designer in the suburbs of Philadelphia. He loves action, exploration, building, filling bars, and turning numbers into bigger numbers. Someday he'll release a video game.</p></div></div><div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"> <img src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2017/03/logo-pixlr-1.png"/><meta itemprop="url" content="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2017/03/logo-pixlr-1.png"></div><meta itemprop="name" content="KnowTechie"></div></div><div id="mvp-comments-button" class="left relative mvp-com-click"> <span class="mvp-comment-but-text"><span class="dsq-postid" data-dsqidentifier="100689 https://knowtechie.com/?p=100689">Comments</span></span></div><div id="disqus_thread" class="disqus-thread-100689"></div> <script type="text/javascript">var disqus_shortname = "knowtechie";
        var disqus_title = "Review: Fell Seal: Arbiter’s Mark will scratch that tactical RPG itch quite well";
        var disqus_url = "https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/";
        var disqus_identifier = "knowtechie-100689";</script> </div></div></div></div></div><div id="mvp-side-wrap" class="relative"> <section id="mvp_tabber_widget-11" class="mvp-side-widget mvp_tabber_widget"><div class="mvp-side-tab-wrap left relative"><div class="mvp-side-tab-top left relative"><ul class="mvp-side-tab-list mvp-col-tabs"><li class="mvp-feat-col-tab"> <a href="#mvp-tab-col1"><span class="mvp-side-tab-head"><i class="fa fa-clock-o" aria-hidden="true"></i> Headlines</span></a></li><li> <a href="#mvp-tab-col2"><span class="mvp-side-tab-head"><i class="fa fa-bolt" aria-hidden="true"></i> Trending</span></a></li><li> <a href="#mvp-tab-col3"><span class="mvp-side-tab-head"><i class="fa fa-play-circle-o" aria-hidden="true"></i> Videos</span></a></li></ul></div><div id="mvp-tab-col1" class="mvp-side-tab-main left relative mvp-tab-col-cont"><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/the-panic-room-terminator-is-literally-happening-before-our-eyes/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></noscript></noscript></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>Internet</h3><h2><a href="https://knowtechie.com/the-panic-room-terminator-is-literally-happening-before-our-eyes/" rel="bookmark">The Panic Room: Terminator is literally happening before our eyes</a></h2></div></div></div></div><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/knowtechie-roundtable-what-games-would-you-like-to-see-add-a-battle-royale-mode/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="battle royale games" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-912x912.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="battle royale games" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-912x912.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="battle royale games" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-912x912.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></noscript></noscript></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>Roundtable</h3><h2><a href="https://knowtechie.com/knowtechie-roundtable-what-games-would-you-like-to-see-add-a-battle-royale-mode/" rel="bookmark">KnowTechie Roundtable: What games would you like to see add a battle royale mode?</a></h2></div></div></div></div><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/knowtechie-giveaway-win-a-lifetime-plex-pass/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></noscript></noscript></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>Giveaway</h3><h2><a href="https://knowtechie.com/knowtechie-giveaway-win-a-lifetime-plex-pass/" rel="bookmark">KnowTechie Giveaway: Win a Lifetime Plex Pass</a></h2></div></div></div></div><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="fell seal arbiters mark gameplay" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="fell seal arbiters mark gameplay" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="fell seal arbiters mark gameplay" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></noscript></noscript></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>#GameTechie</h3><h2><a href="https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/" rel="bookmark">Review: Fell Seal: Arbiter’s Mark will scratch that tactical RPG itch quite well</a></h2></div></div></div></div><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/here-are-the-best-games-of-the-show-from-pax-west-2019/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="pax west 2019 logo" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="pax west 2019 logo" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="pax west 2019 logo" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></noscript></noscript></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>#GameTechie</h3><h2><a href="https://knowtechie.com/here-are-the-best-games-of-the-show-from-pax-west-2019/" rel="bookmark">Here are the best games of the show from PAX West 2019</a></h2></div></div></div></div><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/this-hybrid-smartwatch-from-sequent-gets-its-power-from-your-movements/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SEQ-PREMIUM-MACRO-03-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="sequent self-charging smartwatch" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SEQ-PREMIUM-MACRO-03-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SEQ-PREMIUM-MACRO-03-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SEQ-PREMIUM-MACRO-03-912x912.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SEQ-PREMIUM-MACRO-03-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SEQ-PREMIUM-MACRO-03-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SEQ-PREMIUM-MACRO-03-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="sequent self-charging smartwatch" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SEQ-PREMIUM-MACRO-03-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SEQ-PREMIUM-MACRO-03-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SEQ-PREMIUM-MACRO-03-912x912.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SEQ-PREMIUM-MACRO-03-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SEQ-PREMIUM-MACRO-03-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SEQ-PREMIUM-MACRO-03-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="sequent self-charging smartwatch" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SEQ-PREMIUM-MACRO-03-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SEQ-PREMIUM-MACRO-03-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SEQ-PREMIUM-MACRO-03-912x912.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SEQ-PREMIUM-MACRO-03-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SEQ-PREMIUM-MACRO-03-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></noscript></noscript></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>Gadgets</h3><h2><a href="https://knowtechie.com/this-hybrid-smartwatch-from-sequent-gets-its-power-from-your-movements/" rel="bookmark">This hybrid smartwatch from Sequent gets its power from your movements</a></h2></div></div></div></div><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/spotify-users-can-now-share-their-favorite-tracks-on-snapchat-heres-how/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SNAPCHAT_TO_SPOTIFY_PR_ASSET_1920x733_V3-1-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="sharing spotify songs on instagram" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SNAPCHAT_TO_SPOTIFY_PR_ASSET_1920x733_V3-1-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SNAPCHAT_TO_SPOTIFY_PR_ASSET_1920x733_V3-1-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SNAPCHAT_TO_SPOTIFY_PR_ASSET_1920x733_V3-1-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SNAPCHAT_TO_SPOTIFY_PR_ASSET_1920x733_V3-1-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SNAPCHAT_TO_SPOTIFY_PR_ASSET_1920x733_V3-1-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SNAPCHAT_TO_SPOTIFY_PR_ASSET_1920x733_V3-1-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="sharing spotify songs on instagram" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SNAPCHAT_TO_SPOTIFY_PR_ASSET_1920x733_V3-1-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SNAPCHAT_TO_SPOTIFY_PR_ASSET_1920x733_V3-1-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SNAPCHAT_TO_SPOTIFY_PR_ASSET_1920x733_V3-1-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SNAPCHAT_TO_SPOTIFY_PR_ASSET_1920x733_V3-1-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SNAPCHAT_TO_SPOTIFY_PR_ASSET_1920x733_V3-1-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SNAPCHAT_TO_SPOTIFY_PR_ASSET_1920x733_V3-1-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="sharing spotify songs on instagram" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SNAPCHAT_TO_SPOTIFY_PR_ASSET_1920x733_V3-1-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SNAPCHAT_TO_SPOTIFY_PR_ASSET_1920x733_V3-1-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SNAPCHAT_TO_SPOTIFY_PR_ASSET_1920x733_V3-1-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SNAPCHAT_TO_SPOTIFY_PR_ASSET_1920x733_V3-1-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/SNAPCHAT_TO_SPOTIFY_PR_ASSET_1920x733_V3-1-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></noscript></noscript></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>News</h3><h2><a href="https://knowtechie.com/spotify-users-can-now-share-their-favorite-tracks-on-snapchat-heres-how/" rel="bookmark">Spotify users can now share their favorite tracks on Snapchat &#8211; Here’s how</a></h2></div></div></div></div><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/review-rad-an-80s-retro-apocalyptic-foray-into-mutant-action/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="rad review for nintendo switch" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="rad review for nintendo switch" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="rad review for nintendo switch" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></noscript></noscript></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>#GameTechie</h3><h2><a href="https://knowtechie.com/review-rad-an-80s-retro-apocalyptic-foray-into-mutant-action/" rel="bookmark">Review: RAD &#8211; an 80s retro-apocalyptic foray into mutant action</a></h2></div></div></div></div></div><div id="mvp-tab-col2" class="mvp-side-tab-main left relative mvp-tab-col-cont"><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/knowtechie-giveaway-win-a-lifetime-plex-pass/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/plex-pass-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></noscript></noscript></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>Giveaway</h3><h2><a href="https://knowtechie.com/knowtechie-giveaway-win-a-lifetime-plex-pass/" rel="bookmark">KnowTechie Giveaway: Win a Lifetime Plex Pass</a></h2></div></div></div></div><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/knowtechie-roundtable-what-games-would-you-like-to-see-add-a-battle-royale-mode/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="battle royale games" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-912x912.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="battle royale games" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-912x912.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="battle royale games" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-912x912.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/battle-royale-games-knowtechie-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></noscript></noscript></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>Roundtable</h3><h2><a href="https://knowtechie.com/knowtechie-roundtable-what-games-would-you-like-to-see-add-a-battle-royale-mode/" rel="bookmark">KnowTechie Roundtable: What games would you like to see add a battle royale mode?</a></h2></div></div></div></div><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/the-panic-room-terminator-is-literally-happening-before-our-eyes/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/jared-terminator-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></noscript></noscript></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>Internet</h3><h2><a href="https://knowtechie.com/the-panic-room-terminator-is-literally-happening-before-our-eyes/" rel="bookmark">The Panic Room: Terminator is literally happening before our eyes</a></h2></div></div></div></div><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/review-air-trio-all-one-wireless-charging-dock-extremely-clutch/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/air-trio-knowtechie-review-4-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="air trio iphone charger knowtechie review" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/air-trio-knowtechie-review-4-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/air-trio-knowtechie-review-4-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/air-trio-knowtechie-review-4-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/air-trio-knowtechie-review-4-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/air-trio-knowtechie-review-4-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/air-trio-knowtechie-review-4-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="air trio iphone charger knowtechie review" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/air-trio-knowtechie-review-4-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/air-trio-knowtechie-review-4-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/air-trio-knowtechie-review-4-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/air-trio-knowtechie-review-4-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/air-trio-knowtechie-review-4-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/air-trio-knowtechie-review-4-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="air trio iphone charger knowtechie review" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/air-trio-knowtechie-review-4-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/air-trio-knowtechie-review-4-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/air-trio-knowtechie-review-4-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/air-trio-knowtechie-review-4-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/air-trio-knowtechie-review-4-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></noscript></noscript></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>Gadgets</h3><h2><a href="https://knowtechie.com/review-air-trio-all-one-wireless-charging-dock-extremely-clutch/" rel="bookmark">Review: Air Trio all-one-wireless charging dock – extremely clutch</a></h2></div></div></div></div><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/neuralcam-is-the-first-night-mode-camera-app-for-the-iphone-and-the-results-are-incredible/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/neuralcam-night-mode-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="neuralcam night mode camera" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/neuralcam-night-mode-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/neuralcam-night-mode-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/neuralcam-night-mode-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/neuralcam-night-mode-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/neuralcam-night-mode-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/neuralcam-night-mode-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="neuralcam night mode camera" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/neuralcam-night-mode-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/neuralcam-night-mode-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/neuralcam-night-mode-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/neuralcam-night-mode-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/neuralcam-night-mode-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/neuralcam-night-mode-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="neuralcam night mode camera" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/neuralcam-night-mode-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/neuralcam-night-mode-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/neuralcam-night-mode-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/neuralcam-night-mode-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/neuralcam-night-mode-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></noscript></noscript></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>Apps</h3><h2><a href="https://knowtechie.com/neuralcam-is-the-first-night-mode-camera-app-for-the-iphone-and-the-results-are-incredible/" rel="bookmark">NeuralCam is the first Night Mode camera app for the iPhone and the results are incredible</a></h2></div></div></div></div><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/zao-is-a-chinese-deepfake-app-that-puts-your-face-into-famous-movies-and-its-blowing-up-like-crazy/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/02/deepfake-jlaw-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="deepfakes ai steve buscemi jennifer lawrence" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/02/deepfake-jlaw-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/02/deepfake-jlaw-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/02/deepfake-jlaw-912x899.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/02/deepfake-jlaw-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/02/deepfake-jlaw-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/02/deepfake-jlaw-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="deepfakes ai steve buscemi jennifer lawrence" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/02/deepfake-jlaw-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/02/deepfake-jlaw-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/02/deepfake-jlaw-912x899.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/02/deepfake-jlaw-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/02/deepfake-jlaw-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/02/deepfake-jlaw-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="deepfakes ai steve buscemi jennifer lawrence" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/02/deepfake-jlaw-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/02/deepfake-jlaw-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/02/deepfake-jlaw-912x899.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/02/deepfake-jlaw-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/02/deepfake-jlaw-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></noscript></noscript></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>News</h3><h2><a href="https://knowtechie.com/zao-is-a-chinese-deepfake-app-that-puts-your-face-into-famous-movies-and-its-blowing-up-like-crazy/" rel="bookmark">Zao is a Chinese deepfake app that puts your face into famous movies and it’s blowing up like crazy</a></h2></div></div></div></div></div><div id="mvp-tab-col3" class="mvp-side-tab-main left relative mvp-tab-col-cont"><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/samsungs-airdresser-is-a-closet-that-cleans-and-straightens-your-clothes-and-i-need-it/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/sec4_img_1-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="samsung airdresser" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/sec4_img_1-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/sec4_img_1-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/sec4_img_1-912x902.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/sec4_img_1-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/sec4_img_1-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/sec4_img_1-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="samsung airdresser" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/sec4_img_1-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/sec4_img_1-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/sec4_img_1-912x902.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/sec4_img_1-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/sec4_img_1-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/sec4_img_1-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="samsung airdresser" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/sec4_img_1-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/sec4_img_1-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/sec4_img_1-912x902.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/sec4_img_1-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/sec4_img_1-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></noscript></noscript><div class="mvp-vid-box-wrap"> <i class="fa fa-2 fa-play" aria-hidden="true"></i></div></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>Gadgets</h3><h2><a href="https://knowtechie.com/samsungs-airdresser-is-a-closet-that-cleans-and-straightens-your-clothes-and-i-need-it/" rel="bookmark">Samsung’s AirDresser is a closet that cleans and straightens your clothes and I need it</a></h2></div></div></div></div><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/heres-what-the-newest-nintendo-direct-looked-like-to-an-11-year-old/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="mario and sonic go the the olympics tokyo 2020" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="mario and sonic go the the olympics tokyo 2020" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="mario and sonic go the the olympics tokyo 2020" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></noscript></noscript><div class="mvp-vid-box-wrap"> <i class="fa fa-2 fa-play" aria-hidden="true"></i></div></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>#GameTechie</h3><h2><a href="https://knowtechie.com/heres-what-the-newest-nintendo-direct-looked-like-to-an-11-year-old/" rel="bookmark">Here&#8217;s what the newest Nintendo Direct event looked like to an 11-year old</a></h2></div></div></div></div><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/outbuddies-is-a-metroidvania-6-years-in-the-making-and-its-almost-here/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="outbuddies screenshot" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="outbuddies screenshot" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="outbuddies screenshot" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></noscript></noscript><div class="mvp-vid-box-wrap"> <i class="fa fa-2 fa-play" aria-hidden="true"></i></div></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>#GameTechie</h3><h2><a href="https://knowtechie.com/outbuddies-is-a-metroidvania-6-years-in-the-making-and-its-almost-here/" rel="bookmark">Outbuddies is a Metroidvania 6 years in the making and it&#8217;s almost here</a></h2></div></div></div></div><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/hot-shot-burn-is-a-local-multiplayer-arena-game-with-the-best-synthwave-soundtrack-pax-west-2019/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="hot shot burn gameplay" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-912x912.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="hot shot burn gameplay" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-912x912.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="hot shot burn gameplay" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-912x912.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></noscript></noscript><div class="mvp-vid-box-wrap"> <i class="fa fa-2 fa-play" aria-hidden="true"></i></div></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>#GameTechie</h3><h2><a href="https://knowtechie.com/hot-shot-burn-is-a-local-multiplayer-arena-game-with-the-best-synthwave-soundtrack-pax-west-2019/" rel="bookmark">Hot Shot Burn is a local multiplayer arena game with the best synthwave soundtrack &#8211; PAX West 2019</a></h2></div></div></div></div><div class="mvp-side-tab-story left relative"><div class="mvp-side-tab-out relative"> <a href="https://knowtechie.com/stranded-sails-is-a-peaceful-game-about-exploration-and-farming-pax-west-2019/" rel="bookmark"><div class="mvp-side-tab-img left relative"> <img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/stranded-islands-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="stranded sails gameplay" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/stranded-islands-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/stranded-islands-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/stranded-islands-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/stranded-islands-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/stranded-islands-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/stranded-islands-80x80.jpg" class="lazy lazy-hidden attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="stranded sails gameplay" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/stranded-islands-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/stranded-islands-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/stranded-islands-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/stranded-islands-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/stranded-islands-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/stranded-islands-80x80.jpg" class="attachment-mvp-small-thumb size-mvp-small-thumb wp-post-image" alt="stranded sails gameplay" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/stranded-islands-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/stranded-islands-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/stranded-islands-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/stranded-islands-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/stranded-islands-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></noscript></noscript><div class="mvp-vid-box-wrap"> <i class="fa fa-2 fa-play" aria-hidden="true"></i></div></div> </a><div class="mvp-side-tab-in"><div class="mvp-side-tab-text left relative"><h3>#GameTechie</h3><h2><a href="https://knowtechie.com/stranded-sails-is-a-peaceful-game-about-exploration-and-farming-pax-west-2019/" rel="bookmark">Stranded Sails is a peaceful game about exploration and farming &#8211; PAX West 2019</a></h2></div></div></div></div></div></div></section><div class="mvp-widget-ad left relative"> <span class="mvp-ad-label">Advertisement</span> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:inline-block;width:300px;height:600px"
data-ad-client="ca-pub-5956380843928535"
data-ad-slot="2512586079"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div></div> <section id="mvp-more-post-wrap" class="left relative"><h4 class="mvp-sec-head"><span class="mvp-sec-head">More in #GameTechie</span></h4><ul class="mvp-more-post-list left relative"><li> <a href="https://knowtechie.com/here-are-the-best-games-of-the-show-from-pax-west-2019/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-400x240.jpg" class="lazy lazy-hidden mvp-reg-img wp-post-image" alt="pax west 2019 logo" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-400x240.jpg 400w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /><noscript><img width="400" height="240" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-400x240.jpg" class="mvp-reg-img wp-post-image" alt="pax west 2019 logo" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-400x240.jpg 400w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></noscript> <img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-80x80.jpg" class="lazy lazy-hidden mvp-mob-img wp-post-image" alt="pax west 2019 logo" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-80x80.jpg" class="mvp-mob-img wp-post-image" alt="pax west 2019 logo" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/pax-west-2019-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></noscript></div> </a><div class="mvp-more-post-text left relative"><h2><a href="https://knowtechie.com/here-are-the-best-games-of-the-show-from-pax-west-2019/" rel="bookmark">Here are the best games of the show from PAX West 2019</a></h2><p>I wish I had time to cover everything, but these are some of my...</p></div></li><li> <a href="https://knowtechie.com/review-rad-an-80s-retro-apocalyptic-foray-into-mutant-action/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-400x240.jpg" class="lazy lazy-hidden mvp-reg-img wp-post-image" alt="rad review for nintendo switch" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-400x240.jpg 400w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /><noscript><img width="400" height="240" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-400x240.jpg" class="mvp-reg-img wp-post-image" alt="rad review for nintendo switch" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-400x240.jpg 400w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></noscript> <img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-80x80.jpg" class="lazy lazy-hidden mvp-mob-img wp-post-image" alt="rad review for nintendo switch" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-80x80.jpg" class="mvp-mob-img wp-post-image" alt="rad review for nintendo switch" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/08/rad-review-knowtechie-nintendo-switch-6-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></noscript></div> </a><div class="mvp-more-post-text left relative"><h2><a href="https://knowtechie.com/review-rad-an-80s-retro-apocalyptic-foray-into-mutant-action/" rel="bookmark">Review: RAD &#8211; an 80s retro-apocalyptic foray into mutant action</a></h2><p>A gorgeous roguelike that barely misses the mark.</p></div></li><li> <a href="https://knowtechie.com/psa-youve-been-mislabeling-one-of-the-playstation-controller-buttons-since-forever/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2018/09/playstation-4-controller-e1558446342218-400x240.jpg" class="lazy lazy-hidden mvp-reg-img wp-post-image" alt="sony playstation 4 white controller and console in the background apple tv" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2018/09/playstation-4-controller-e1558446342218-400x240.jpg 400w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2018/09/playstation-4-controller-e1558446342218-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /><noscript><img width="400" height="240" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2018/09/playstation-4-controller-e1558446342218-400x240.jpg" class="mvp-reg-img wp-post-image" alt="sony playstation 4 white controller and console in the background apple tv" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2018/09/playstation-4-controller-e1558446342218-400x240.jpg 400w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2018/09/playstation-4-controller-e1558446342218-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></noscript> <img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2018/09/playstation-4-controller-e1558446342218-80x80.jpg" class="lazy lazy-hidden mvp-mob-img wp-post-image" alt="sony playstation 4 white controller and console in the background apple tv" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2018/09/playstation-4-controller-e1558446342218-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2018/09/playstation-4-controller-e1558446342218-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2018/09/playstation-4-controller-e1558446342218-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2018/09/playstation-4-controller-e1558446342218-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2018/09/playstation-4-controller-e1558446342218-80x80.jpg" class="mvp-mob-img wp-post-image" alt="sony playstation 4 white controller and console in the background apple tv" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2018/09/playstation-4-controller-e1558446342218-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2018/09/playstation-4-controller-e1558446342218-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2018/09/playstation-4-controller-e1558446342218-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2018/09/playstation-4-controller-e1558446342218-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></noscript></div> </a><div class="mvp-more-post-text left relative"><h2><a href="https://knowtechie.com/psa-youve-been-mislabeling-one-of-the-playstation-controller-buttons-since-forever/" rel="bookmark">PSA: You&#8217;ve been mislabeling one of the PlayStation controller buttons since forever</a></h2><p>Okay, now I'm cross...</p></div></li><li> <a href="https://knowtechie.com/doom-bone-vodka-will-get-you-demon-drunk-on-your-way-to-hell/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/doom-bone-vodka-400x240.jpg" class="lazy lazy-hidden mvp-reg-img wp-post-image" alt="doom bone vodka" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/doom-bone-vodka-400x240.jpg 400w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/doom-bone-vodka-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /><noscript><img width="400" height="240" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/doom-bone-vodka-400x240.jpg" class="mvp-reg-img wp-post-image" alt="doom bone vodka" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/doom-bone-vodka-400x240.jpg 400w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/doom-bone-vodka-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></noscript> <img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/doom-bone-vodka-80x80.jpg" class="lazy lazy-hidden mvp-mob-img wp-post-image" alt="doom bone vodka" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/doom-bone-vodka-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/doom-bone-vodka-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/doom-bone-vodka-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/doom-bone-vodka-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/doom-bone-vodka-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/doom-bone-vodka-80x80.jpg" class="mvp-mob-img wp-post-image" alt="doom bone vodka" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/doom-bone-vodka-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/doom-bone-vodka-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/doom-bone-vodka-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/doom-bone-vodka-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/doom-bone-vodka-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></noscript></div> </a><div class="mvp-more-post-text left relative"><h2><a href="https://knowtechie.com/doom-bone-vodka-will-get-you-demon-drunk-on-your-way-to-hell/" rel="bookmark">Doom Bone Vodka will get you demon drunk on your way to hell</a></h2><p>I'd rather drink motor oil and play Excitebike.</p></div></li><li> <a href="https://knowtechie.com/heres-what-the-newest-nintendo-direct-looked-like-to-an-11-year-old/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-400x240.jpg" class="lazy lazy-hidden mvp-reg-img wp-post-image" alt="mario and sonic go the the olympics tokyo 2020" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-400x240.jpg 400w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /><noscript><img width="400" height="240" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-400x240.jpg" class="mvp-reg-img wp-post-image" alt="mario and sonic go the the olympics tokyo 2020" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-400x240.jpg 400w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></noscript> <img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-80x80.jpg" class="lazy lazy-hidden mvp-mob-img wp-post-image" alt="mario and sonic go the the olympics tokyo 2020" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-80x80.jpg" class="mvp-mob-img wp-post-image" alt="mario and sonic go the the olympics tokyo 2020" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-912x900.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/03/mario-sonic-olympics-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></noscript><div class="mvp-vid-box-wrap"> <i class="fa fa-2 fa-play" aria-hidden="true"></i></div></div> </a><div class="mvp-more-post-text left relative"><h2><a href="https://knowtechie.com/heres-what-the-newest-nintendo-direct-looked-like-to-an-11-year-old/" rel="bookmark">Here&#8217;s what the newest Nintendo Direct event looked like to an 11-year old</a></h2><p>"There's a new old controller you can use to play old games on the...</p></div></li><li> <a href="https://knowtechie.com/outbuddies-is-a-metroidvania-6-years-in-the-making-and-its-almost-here/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-400x240.jpg" class="lazy lazy-hidden mvp-reg-img wp-post-image" alt="outbuddies screenshot" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-400x240.jpg 400w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /><noscript><img width="400" height="240" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-400x240.jpg" class="mvp-reg-img wp-post-image" alt="outbuddies screenshot" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-400x240.jpg 400w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></noscript> <img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-80x80.jpg" class="lazy lazy-hidden mvp-mob-img wp-post-image" alt="outbuddies screenshot" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-80x80.jpg" class="mvp-mob-img wp-post-image" alt="outbuddies screenshot" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/outbuddies-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></noscript><div class="mvp-vid-box-wrap"> <i class="fa fa-2 fa-play" aria-hidden="true"></i></div></div> </a><div class="mvp-more-post-text left relative"><h2><a href="https://knowtechie.com/outbuddies-is-a-metroidvania-6-years-in-the-making-and-its-almost-here/" rel="bookmark">Outbuddies is a Metroidvania 6 years in the making and it&#8217;s almost here</a></h2><p>I'm definitely interested in seeing the full version of this when it drops on...</p></div></li><li> <a href="https://knowtechie.com/epic-tavern-is-a-reverse-rpg-game-where-youre-the-tavenmaster-in-a-wild-fantasy-land/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/epic-tavern-screenshot-400x240.jpg" class="lazy lazy-hidden mvp-reg-img wp-post-image" alt="Epic Tavern" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/epic-tavern-screenshot-400x240.jpg 400w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/epic-tavern-screenshot-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /><noscript><img width="400" height="240" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/epic-tavern-screenshot-400x240.jpg" class="mvp-reg-img wp-post-image" alt="Epic Tavern" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/epic-tavern-screenshot-400x240.jpg 400w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/epic-tavern-screenshot-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></noscript> <img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/epic-tavern-screenshot-80x80.jpg" class="lazy lazy-hidden mvp-mob-img wp-post-image" alt="Epic Tavern" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/epic-tavern-screenshot-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/epic-tavern-screenshot-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/epic-tavern-screenshot-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/epic-tavern-screenshot-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/epic-tavern-screenshot-80x80.jpg" class="mvp-mob-img wp-post-image" alt="Epic Tavern" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/epic-tavern-screenshot-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/epic-tavern-screenshot-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/epic-tavern-screenshot-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/epic-tavern-screenshot-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></noscript></div> </a><div class="mvp-more-post-text left relative"><h2><a href="https://knowtechie.com/epic-tavern-is-a-reverse-rpg-game-where-youre-the-tavenmaster-in-a-wild-fantasy-land/" rel="bookmark">Epic Tavern is a reverse-RPG game where you&#8217;re the Tavenmaster in a wild fantasy land</a></h2><p>There isn't quite anything like this one out there.</p></div></li><li> <a href="https://knowtechie.com/hot-shot-burn-is-a-local-multiplayer-arena-game-with-the-best-synthwave-soundtrack-pax-west-2019/" rel="bookmark"><div class="mvp-more-post-img left relative"> <img width="400" height="240" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-400x240.jpg" class="lazy lazy-hidden mvp-reg-img wp-post-image" alt="hot shot burn gameplay" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-400x240.jpg 400w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /><noscript><img width="400" height="240" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-400x240.jpg" class="mvp-reg-img wp-post-image" alt="hot shot burn gameplay" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-400x240.jpg 400w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-1000x600.jpg 1000w" sizes="(max-width: 400px) 100vw, 400px" /></noscript> <img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-80x80.jpg" class="lazy lazy-hidden mvp-mob-img wp-post-image" alt="hot shot burn gameplay" srcset="" data-srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-912x912.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /><noscript><img width="80" height="80" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-80x80.jpg" class="mvp-mob-img wp-post-image" alt="hot shot burn gameplay" srcset="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-80x80.jpg 80w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-150x150.jpg 150w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-912x912.jpg 912w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-550x550.jpg 550w, https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/hot-shot-burn-1-470x470.jpg 470w" sizes="(max-width: 80px) 100vw, 80px" /></noscript><div class="mvp-vid-box-wrap"> <i class="fa fa-2 fa-play" aria-hidden="true"></i></div></div> </a><div class="mvp-more-post-text left relative"><h2><a href="https://knowtechie.com/hot-shot-burn-is-a-local-multiplayer-arena-game-with-the-best-synthwave-soundtrack-pax-west-2019/" rel="bookmark">Hot Shot Burn is a local multiplayer arena game with the best synthwave soundtrack &#8211; PAX West 2019</a></h2><p>The soundtrack alone makes this one worth it.</p></div></li></ul> </section><div id="mvp-prev-next-wrap"><div id="mvp-prev-post-wrap"><div id="mvp-prev-post-arrow" class="relative"> <span class="fa fa-angle-left fa-4" aria-hidden="true"></span></div><div class="mvp-prev-next-text"> <a href="https://knowtechie.com/here-are-the-best-games-of-the-show-from-pax-west-2019/" rel="prev">Here are the best games of the show from PAX West 2019</a></div></div></div></div> </article></div></div></div> </main> <footer id="mvp-foot-wrap" class="left relative"><div id="mvp-foot-top" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-foot-logo" class="left relative"> <a href="https://knowtechie.com/"><img src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/04/klogo.png" alt="KnowTechie" data-rjs="2" /></a></div><div id="mvp-foot-soc" class="left relative"><ul class="mvp-foot-soc-list left relative"><li><a href="http://facebook.com/knowtechie" target="_blank" class="fa fa-facebook-official fa-2"></a></li><li><a href="http://twitter.com/knowtechie" target="_blank" class="fa fa-twitter fa-2"></a></li><li><a href="https://www.pinterest.com/KnowTechie/" target="_blank" class="fa fa-pinterest-p fa-2"></a></li><li><a href="https://plus.google.com/+KnowTechiePlus" target="_blank" class="fa fa-google-plus fa-2"></a></li><li><a href="https://www.youtube.com/channel/UCjpgYyUblbKvNtElLOFi2jw" target="_blank" class="fa fa-youtube-play fa-2"></a></li></ul></div></div></div><div id="mvp-foot-bot" class="left relative"><div id="mvp-foot-menu-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-foot-menu" class="left relative"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-21799" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-21799"><a href="https://knowtechie.com">Home</a></li><li id="menu-item-23878" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23878"><a href="https://knowtechie.com/about/">About Us</a></li><li id="menu-item-22004" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22004"><a href="https://knowtechie.com/contact/">Contact</a></li><li id="menu-item-45920" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-45920"><a href="https://knowtechie.com/disclosure/">Disclosures</a></li><li id="menu-item-62571" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-62571"><a href="https://knowtechie.com/privacy-policy/">Privacy Policy</a></li></ul></div></div></div></div><div id="mvp-foot-copy-wrap" class="left relative"><div class="mvp-main-box-cont"><div id="mvp-foot-copy" class="left relative"><p>Copyright © 2019 KnowTechie</p></div></div></div></div> </footer><div id="mvp-mob-soc-wrap" class="left relative"> <span class="mvp-mob-soc-share-but fa fa-share fa-2 mvp-mob-soc-click" aria-hidden="true"></span><ul class="mvp-mob-soc-list left relative"> <a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/&amp;t=Review: Fell Seal: Arbiter’s Mark will scratch that tactical RPG itch quite well', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><li class="mvp-mob-soc-fb"> <i class="fa fa-2 fa-facebook" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://twitter.com/share?text=Review: Fell Seal: Arbiter’s Mark will scratch that tactical RPG itch quite well -&amp;url=https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><li class="mvp-mob-soc-twit"> <i class="fa fa-2 fa-twitter" aria-hidden="true"></i></li> </a> <a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/&amp;media=https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/2019/09/fell-seal-arbiters-mark-knowtechie-review-nintendo-switch-6-1000x600.jpg&amp;description=Review: Fell Seal: Arbiter’s Mark will scratch that tactical RPG itch quite well', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><li class="mvp-mob-soc-pin"> <i class="fa fa-2 fa-pinterest-p" aria-hidden="true"></i></li> </a> <a href="mailto:?subject=Review: Fell Seal: Arbiter’s Mark will scratch that tactical RPG itch quite well&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://knowtechie.com/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well/"><li class="mvp-mob-soc-email"> <i class="fa fa-2 fa-envelope" aria-hidden="true"></i></li> </a></ul></div></div><div class="mvp-fly-top back-to-top"> <i class="fa fa-angle-up fa-3"></i></div><div class="mvp-fly-fade mvp-fly-but-click"></div> <script type='text/javascript' defer src='https://kt-media-knowtechie.netdna-ssl.com/wp-content/themes/the-league/js/scripts.js'></script> <script type="text/javascript" src="//downloads.mailchimp.com/js/signup-forms/popup/unique-methods/embed.js" data-dojo-config="usePlainJson: true, isDebug: false"></script><script type="text/javascript">window.dojoRequire(["mojo/signup-forms/Loader"], function(L) { L.start({"baseUrl":"mc.us9.list-manage.com","uuid":"46874d934f5e84d75487b76e6","lid":"ef0d56fdd0","uniqueMethods":true}) })</script> <div id="amzn-assoc-ad-ba998574-729d-4553-9315-a0785d079942"></div><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=ba998574-729d-4553-9315-a0785d079942"></script>  <script async id="cached-script" src="https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/cached-scripts/gtag.js"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-51813050-1');</script> <script src="//www.anrdoezrs.net/am/7857194/include/allCj/impressions/page/am.js"></script> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-5956380843928535",
     });</script> <amp-ad width="100vw" height=320
type="adsense"
data-ad-client="ca-pub-5956380843928535"
data-ad-slot="1804298207"
data-auto-format="rspv"
data-full-width><div overflow></div> </amp-ad> <script type="text/javascript">(function(i,m,p,a,c,t){c.ire_o=p;c[p]=c[p]||function(){(c[p].a=c[p].a||[]).push(arguments)};t=a.createElement(m);var z=a.getElementsByTagName(m)[0];t.async=1;t.src=i;z.parentNode.insertBefore(t,z)})('//d.impactradius-event.com/P-A226927-24f2-4e20-b75c-8bf12e4f51dd1.js','script','impactStat',document,window);impactStat('transformLinks');impactStat('trackImpression');</script> <div data-theiaStickySidebar-sidebarSelector='"#mvp-side-wrap, #mvp-post-soc-wrap"'
data-theiaStickySidebar-options='{"containerSelector":"","additionalMarginTop":124,"additionalMarginBottom":45,"updateSidebarHeight":false,"minWidth":0,"sidebarBehavior":"stick-to-bottom","disableOnResponsiveLayouts":true}'></div> <script>var amzn_ps_tracking_id = 'knowt01-20';
  	  var amzn_ps_instance_id = 'c2ce9440-3a0d-461d-88d4-48ffb7378891';</script><script type="text/javascript">if(fvmuag()){loadAsync('https://kt-media-knowtechie.netdna-ssl.com/wp-content/themes/the-league/js/mvpcustom.js', null);}</script><script type="text/javascript">if(fvmuag()){loadAsync('https://kt-media-knowtechie.netdna-ssl.com/wp-content/themes/the-league/js/scripts.js', null);}</script><script type='text/javascript' defer src='https://kt-media-knowtechie.netdna-ssl.com/wp-content/themes/the-league/js/mvpcustom.js'></script> <script type='text/javascript'>jQuery(document).ready(function($) {
	$(window).load(function(){
	var aboveHeight = $("#mvp-top-head-wrap").outerHeight();
	$(window).scroll(function(event){
	    	if ($(window).scrollTop() > aboveHeight){
	    		$("#mvp-top-head-wrap").addClass("mvp-score-up");
			$("#mvp-wallpaper").addClass("mvp-wall-up");
			$("#mvp-post-trend-wrap").addClass("mvp-post-trend-down");
			$(".mvp-fly-top").addClass("mvp-to-top");
	    	} else {
	    		$("#mvp-top-head-wrap").removeClass("mvp-score-up");
			$("#mvp-wallpaper").removeClass("mvp-wall-up");
			$("#mvp-post-trend-wrap").removeClass("mvp-post-trend-down");
	    		$(".mvp-fly-top").removeClass("mvp-to-top");
	    	}
	});
	});
	});
	

	jQuery(document).ready(function($) {
	// Main Menu Dropdown Toggle
	$(".menu-item-has-children a").click(function(event){
	  event.stopPropagation();
	  location.href = this.href;
  	});

	$(".menu-item-has-children").click(function(){
    	  $(this).addClass("toggled");
    	  if($(".menu-item-has-children").hasClass("toggled"))
    	  {
    	  $(this).children("ul").toggle();
	  $(".mvp-fly-nav-menu").getNiceScroll().resize();
	  }
	  $(this).toggleClass("tog-minus");
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $(".mvp-fly-nav-menu").niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});
	});
	

	jQuery(document).ready(function($) {
	$(".infinite-content").infinitescroll({
	  navSelector: ".mvp-nav-links",
	  nextSelector: ".mvp-nav-links a:first",
	  itemSelector: ".infinite-post",
	  errorCallback: function(){ $(".mvp-inf-more-but").css("display", "none") }
	});
	$(window).unbind(".infscr");
	$(".mvp-inf-more-but").click(function(){
   		$(".infinite-content").infinitescroll("retrieve");
        	return false;
	});
	$(window).load(function(){
		if ($(".mvp-nav-links a").length) {
			$(".mvp-inf-more-but").css("display","inline-block");
		} else {
			$(".mvp-inf-more-but").css("display","none");
		}
	});
	});</script><script type='text/javascript' defer src='https://kt-media-knowtechie.netdna-ssl.com/wp-content/themes/the-league/js/scripts.js'></script><script type='text/javascript'>/*  */
var countVars = {"disqusShortname":"knowtechie"};
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"100689 https:\/\/knowtechie.com\/?p=100689","disqusShortname":"knowtechie","disqusTitle":"Review: Fell Seal: Arbiter\u2019s Mark will scratch that tactical RPG itch quite well","disqusUrl":"https:\/\/knowtechie.com\/review-fell-seal-arbiters-mark-will-scratch-that-tactical-rpg-itch-quite-well\/","postId":"100689"};
var letsReview = {"letsReviewLb":"1"};
var letsReview = {"letsReviewAUrl":"https:\/\/knowtechie.com\/wp-admin\/admin-ajax.php","letsReviewNonce":"7dc37c3d75","letsReviewUReviews":"0"};
var qpprFrontData = {"linkData":{"https:\/\/knowtechie.com\/7-tools-every-data-architect-deserves-use\/":[0,1,""],"https:\/\/knowtechie.com\/sms-audio-biosport-earbuds-review-302\/":[0,0,"https:\/\/knowtechie.com\/review\/sms-audio-biosport-earbuds\/"],"https:\/\/knowtechie.com\/get-an-unlocked-nexus-6-for-just-350-today-on-amazon\/":[0,0,""],"https:\/\/knowtechie.com\/these-bluetooth-speakers-can-stand-up-to-your-shower-but-only-cost-about-25\/":[0,0,""],"https:\/\/knowtechie.com\/heres-6-amazing-amazon-deals-expiring-tonight-midnight\/":[0,0,""],"https:\/\/knowtechie.com\/amazons-slashing-prices-on-a-bunch-of-sandisk-flash-storage-today-only\/":[0,0,""],"https:\/\/knowtechie.com\/amazon-is-discounting-a-bunch-of-computing-and-gaming-gear-for-today-only\/":[0,0,""],"https:\/\/knowtechie.com\/these-two-ridiculous-amazon-tech-deals-are-expiring-tonight-at-midnight\/":[0,0,""],"https:\/\/knowtechie.com\/heres-two-irresistible-deals-on-your-next-pair-of-headphones\/":[0,0,""],"https:\/\/knowtechie.com\/these-award-winning-bluetooth-wireless-earbuds-are-only-20-today-on-amazon\/":[0,0,""],"https:\/\/knowtechie.com\/amazons-selling-a-ton-of-tp-link-networking-gear-today-at-ridiculously-low-prices\/":[0,0,""],"https:\/\/knowtechie.com\/take-look-everbuyings-5-new-phones-available-presale\/":[0,0,""],"https:\/\/knowtechie.com\/jump-everbuying-pre-sale-deal-vkworld-vk700x\/":[0,0,""],"https:\/\/knowtechie.com\/write-phones-everbuying-deal\/":[0,0,""],"https:\/\/knowtechie.com\/everbuying-currently-offering-great-flash-sale-k6000-lollipop-phablet\/":[0,0,""],"https:\/\/knowtechie.com\/everbuyings-new-flash-sale-zuk-z1-cyanogen-phone-incredible-price\/":[0,0,""],"https:\/\/knowtechie.com\/everbuyings-one-week-flash-sale-offers-premium-products-low-price\/":[0,0,""],"https:\/\/knowtechie.com\/4-great-deals-everbuyings-elephone-wednesday-flash-sale\/":[0,0,""],"https:\/\/knowtechie.com\/stock-up-on-great-phone-accessories-and-new-devices-with-everbuyings-xiaomi-brand-sale\/":[0,0,""],"https:\/\/knowtechie.com\/save-doogee-homtom-ht6-5-5-phablet-awesome-coupon-code\/":[0,0,""],"https:\/\/knowtechie.com\/dont-miss-vkworld-vk700-pro-flash-sale\/":[0,0,""],"https:\/\/knowtechie.com\/technological-development-uk\/":[0,0,""]},"siteURL":"https:\/\/knowtechie.com","siteURLq":"https:\/\/knowtechie.com"};
var a3_lazyload_params = {"apply_images":"1","apply_videos":"1"};
var a3_lazyload_extend_params = {"edgeY":"0"};
/*  */</script> <script type='text/javascript' defer src='https://kt-media-knowtechie.netdna-ssl.com/wp-content/uploads/cache/fvm/1568030027/out/footer-6a806ad3.min.js'></script><script>/* loadCSS. [c]2017 Filament Group, Inc. MIT License */
(function(w){if(!w.loadCSS)w.loadCSS=function(){};var rp=loadCSS.relpreload={};rp.support=function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=false}return function(){return ret}}();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){if(link.addEventListener)link.removeEventListener("load",enableStylesheet);else if(link.attachEvent)link.detachEvent("onload",enableStylesheet);link.setAttribute("onload",null);link.media=finalMedia}if(link.addEventListener)link.addEventListener("load",enableStylesheet);else if(link.attachEvent)link.attachEvent("onload",enableStylesheet);setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3E3)};rp.poly=function(){if(rp.support())return;var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss", true);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener)w.addEventListener("load",function(){rp.poly();w.clearInterval(run)});else if(w.attachEvent)w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}if(typeof exports!=="undefined")exports.loadCSS=loadCSS;else w.loadCSS=loadCSS})(typeof global!=="undefined"?global:this);</script></body></html>
<!--
Content Delivery Network via kt-media-knowtechie.netdna-ssl.com

Served from: knowtechie.com @ 2019-09-09 23:19:08 by W3 Total Cache
-->